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		Master PDF Editor Preferences.


In order to open settings Master PDF Editor, choose Tools → Settings in Main menu.

In macOS X, it is Master PDF Editor > Preferences…



General



	Saving documents.
	Create backup file. Master PDF Editor creates a backup copy when saving the document. Backup is created only once.
	Choice destination for «Save As…» documents. Choose folder to open when saving file with «Save As…».
	PDF Specification. Selecting of the required electronic format; set to automatic by default.
	Autosave. Master PDF Editor automatically saves the document for a certain period of time.
	Autosave interval. Selecting the frequency of auto-saving the document.



	History.
	Restore last session when application starts. Master PDF Editor saves and restores all opened documents and panels location when relaunching program.
	Restore last view settings when reopening. If enabled, all view settings are restored when reopening the document.
	Save recent files list. Pinning files to the list of recently used documents. When you open Master PDF Editor, these documents will be displayed in the Recent Files list on the Start page.



	Open documents as new tabs in same window (requires restart). If disabled, each PDF file will be opened as a new application instance. The option is absent on macOS, because there it is set in general system preferences.
	Allow opening same document in multiple tabs. This option is disabled by default.
	Lock file from opening by other instances of Master PDF Editor. Master PDF Editor locks simultaneous opening of the same file; the option is disabled by default.
	Enable scroll wheel zooming. Enables/disabled zoom control with mouse wheel or touchpad when Ctrl is pressed.
	Show Quick actions on text and comments selection. Displaying the quick actions when a text or comment is selected with the help of the Hand tool.
	Show Start page. Display start page with the list of recently opened files and most used functions.

Start page is shown only when there are no documents opened.


System



	Alternative method for PDF render. Alternative way to render PDF on screen, may increase render speed up to 4 times.
	Load all objects separately. If checked (by default) all container objects will be loaded separately. This option is used for ease of editing contained objects. Disable this if you have issues with PDF render.
	Memory/Speed. Allows to preserve operative memory or increase render speed, storing earlier rendered pages in cash.
	Enable logging to file. When enabled, Master PDF Editor saves warnings and errors in a log file while operating.


Forms



	Highlight color. Set color for highlighted PDF forms.
	Required field highlight color. Set color for highlighted required PDF forms.
	Always hide document message bar. Always hide pop up message.


You can set the default settings for newly created PDF forms below on this tab.

	Options. Set default options for creating various forms.
	Line thickness.
	Border Color
	Line style.
	Highlight.



	Export.
	Add full path to filename in export file. Setting the file name when exporting form information.



	Recreate PDF forms when opening. This option allows you to avoid display errors of some forms, but slows down the opening of files when enabled.
	Show warning when opening links. If enabled, a warning notice appears when links are opened.
	Convert static XFA into normal PDF when opening file. If a file contains XFA forms, the PDF is converted into a normal one.


Use Forms → Highlight Forms (Ctrl + H) for forms selection or forms selection reset. (For macOS X: Cmd+H).

On this tab, you also can set default settings for newly created PDF forms.

Editing



	Time before a move or resize starts. Time after object selection before it can be dragged or resized. Prevents random mouse dragging.
	Default font. Set default font settings for application.
	Automatically change font when editing text. Automatic replacement of PDF font for system TTF font when editing text. Automatic replacement happens only if the application finds similar font in the system.
	Exact match only. Disables changing the font to a similar one, and do it only if you have a completely appropriate font.
	Edit Text Elements as Blocks. Editing text elements as blocks.
	Save last editing Toolbars. When closing the program, the last tool is saved enabled it by default the next time you open it.
	Always show Object Inspector. Open the Object Inspector by default.
	Selected text color. Choose a selected text color used by default.


Grid



The grid is used for more accurate objects positioning in the document. If Snap to Grid is on, the object will be automatically aligned by the closest grid line after movement. You can enable/disable this function in View → Snap to Grid menu.

The grid is displayed on screen, but not printed with the document. You can show/hide it in View → Grid.

	Units. Measure units for grid size.
	Width between lines. Width for grid cell.
	Height between lines. Height for grid cell.
	Left offset. Value of grid offset from the left edge.
	Top offset. Value of grid offset from the top edge.
	Subdivision. Number of sub-cells inside each main cell.
	Color. Grid line color selection.
	Line width. Setting the line width of the grid.
	Opacity. Setting the grid opacity.


Lines of sub-cells are lighter than those of main cells.

JavaScript



	Enable JavaScript. Enables or disables JavaScript usage in PDF files.
	Show errors and messages in console. Show errors and messages in console. Outputs all JavaScript messages to the console after executing document’s code. JavaScript console can be opened in Document→ JavaScript Console.
	Enable safe reading mode. When enabled, some Java functions are prohibited.


Comments



Default properties for comments.

	Author. Default name is system username. You can specify any name to set as author when creating comments.
	Type of the comment tool. Select the type of comment type to use for setting default parameters.
	Sticky Note.
	Highlight Text.
	Strikeout Text.
	Underline text.
	Measurements.
	Drawing.
	Typewriter.






Comment preferences.

	Type. Choose type of the Sticky Note appearance: comment, circle, check mark.
	Opacity. Opacity of the following comments: Highlight Text, Strikeout Text, Underline Text, Measurements, and Drawing.
	Color. Color of the comment.
	Size. Size of the Sticky Note.
	Line width. Width of the following comment lines: Underline, Strikeout, Highlight, Measurements, and Drawing.
	Text. Format the text of the Typewriter comment.
	Line Style. Select the appearance of the Typewriter comment.
	Fill Color. Select the fill color for the Typewriter comment.
	Border Color. Select the border color for the Typewriter comment.


Display



	Default Layout and Zoom. Page settings for newly opened and created PDF files.
	Smooth text and images. Choose objects to apply antialiasing.
	Replace Document Colors. If enabled, privies possibility to change font and background color in the document.
	Resolution:
	System PPI. Uses the system PPI setting to display the document on the monitor.
	Custom. Allows to set monitor resolution manually if it’s required for your work or Master PDF Editor incorrectly identified it.





Application relaunch is required for settings to take effect.

Toolbars



Users can configure the number and location of toolbars, as well as a specific set of tools on the Toolbars tab .

	Toolbars. This list contains existing toolbars. It’s enough just to select a toolbar and click the Delete Toolbar button To delete a toolbar. The tools in the selected panel will be displayed in the Current toolbar tools list.
	Add Toolbar. If the text field to the left of this button is filled, then when you click, an empty toolbar with the specified name will be created and added to the list.
	Toolbars customization.


You need to create a toolbar (if it hasn’t already been created) and select it in the Toolbars list to customize it.

The tree-like All tools list contains all available tools that are not added to the selected panel. Tools are divided into categories according to which you can find them in the main menu. Select it in the list and press the ► button to move a tool to the current panel. Select the tool in the Current toolbar tools list containing the tools of the selected panel and press the ◄ button to delete it.

The Separator is not a tool, although it is in the All tools list, beyond the category. This is a graphic separator allowing to divide the tools into categories within one panel. It can be added more than once.

The selected tool in the Current toolbar tools list can be deleted with the ◄ button. It can also be moved up or down with the corresponding ▲ and ▼ buttons relative to other tools.

The Reset All button allows you to reset the toolbars to one of the two predefined ones. The Minimum Tools set contains the minimum required tools in the visible panels, and a few more in the hidden ones. Right-click on any active tool in the main window to show hidden toolbars. There are visible marked toolbars in the drop-down list. From here, panels can be shown or hidden by checking or unchecking.

The Maximum tools set contains already all the available tools that are visible on the toolbars.

Appearance



	Theme. Choose appearance theme out of the list. If Dark Style is enabled, then Fusion Style only is available.
	Icons in menus. Set/remove flag to show/hide icons in main menu. This option doesn’t work for some Linux desktop environments, for example Unity.
	Icons set. Select the set of icons.
	Size. Select the size of icons.
	Icons in menus. Check/uncheck to show or hide icons in the main menu. This option does not work for some Linux desktop shells, such as Unity.


Tab is available on Windows and Linux only.

Keyboard



Settings for keyboard hotkeys (shortcuts) in Master PDF Editor. Here you can set up your shortcut for each menu item. Default shortcuts are listed there: Default hotkeys in Master PDF Editor

 

Email



Email delivery settings for Master PDF Editor.

	Use default program. Launches email client, set as default in your system.
	Use SMTP. The block contains basic settings for SMTP server like address, port, user name and password. These settings are required for email delivery. If you don’t know how to fill these fields, contact your system administrator.


OCR



Master PDF Editor has the functionality of optical character recognition for PDF files, containing image (for example, scanned documents converted to PDF). This functionality enables you to search, fix and copy text in such PDF documents.

	Default path to tesseract ocr data files. This setting provides a possibility to set same folder for several users. Mostly used on servers.
	Additional tesseract ocr config file. Required for deliberate configuration tesseract ocr. Consult user manual to find out more info about tesseract ocr.
	Install languages. Choose languages for text recognition. Look here for additional info.


 

Redaction



On this tab you can set the fill color for the redacted information. The default fill color is black.

If the Use Overlay Text is enabled, an inscription will be used, in addition to filling with solid text. The specific text and settings of the inscription can be set in the area under the checkbox.

Network



Allows to set up Internet connection. If you don’t know required options, contact system administrator.

Application relaunch is required for settings to take effect.

Certificates



Settings for Certificates. Read more about Certificate Manager in Linux.

 

Language



On this tab you can change interface language for Master PDF Editor.

Application relaunch is required for settings to take effect.

Update




Set frequency for automatic update check. You can set to check never, weekly or monthly.

In order to check for updates manually choose Help > Check for update in Main menu.
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