Contents

Introduction.........................................................................................................................5
Overview...............................................................................................................................5
System requirements.............................................................................................................6
Installing Master PDF Editor................................................................................................7
  «Silent» Installation............................................................................................................9
Technical Support..............................................................................................................9
Activation............................................................................................................................10
  Online Activation.............................................................................................................11
  Offline Activation..............................................................................................................12
  License Deactivation.......................................................................................................13
Workspace..........................................................................................................................14
  Main Menu.......................................................................................................................15
    File Menu.......................................................................................................................15
    Edit Menu......................................................................................................................15
    View Menu.....................................................................................................................16
    Insert Menu...................................................................................................................17
    Comments Menu............................................................................................................17
    Forms Menu..................................................................................................................18
    Document Menu............................................................................................................18
  Tools Menu......................................................................................................................19
  Help Menu.......................................................................................................................19
  Context Menu..................................................................................................................20
  Toolbars..........................................................................................................................20
  Document Tab...................................................................................................................20
  Pop Up Message...............................................................................................................21
  Status Bar.........................................................................................................................21
  Navigation Area...............................................................................................................21
  Document Area...............................................................................................................22
  Object Inspector.............................................................................................................22
Preferences.......................................................................................................................23
  System Tab.......................................................................................................................23
  Forms Tab.........................................................................................................................24
  Edit Tab............................................................................................................................25
  JavaScript.........................................................................................................................26
  Comments........................................................................................................................27
  Display Tab.......................................................................................................................28
  Appearance.......................................................................................................................29
  Language Tab...................................................................................................................30
  Update.............................................................................................................................31
Document Properties.......................................................................................................32
  Document Info................................................................................................................32
  Document Security.........................................................................................................33
<table>
<thead>
<tr>
<th>Topic</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial View</td>
<td>35</td>
</tr>
<tr>
<td>Font</td>
<td>36</td>
</tr>
<tr>
<td>Opening and Saving Files</td>
<td>37</td>
</tr>
<tr>
<td>Opening PDF Files</td>
<td>37</td>
</tr>
<tr>
<td>Opening Documents</td>
<td>37</td>
</tr>
<tr>
<td>Opening Protected PDF Document</td>
<td>37</td>
</tr>
<tr>
<td>Recently Opened Documents</td>
<td>38</td>
</tr>
<tr>
<td>Saving PDF Files</td>
<td>38</td>
</tr>
<tr>
<td>Optimisation and Saving</td>
<td>39</td>
</tr>
<tr>
<td>Export PDF to Image</td>
<td>41</td>
</tr>
<tr>
<td>Closing</td>
<td>42</td>
</tr>
<tr>
<td>PDF Files View</td>
<td>43</td>
</tr>
<tr>
<td>Setting View Mode</td>
<td>43</td>
</tr>
<tr>
<td>Document Navigation</td>
<td>43</td>
</tr>
<tr>
<td>Move to Specific Page</td>
<td>43</td>
</tr>
<tr>
<td>Transition with Bookmarks</td>
<td>44</td>
</tr>
<tr>
<td>Transition with Page Thumbnails</td>
<td>44</td>
</tr>
<tr>
<td>Text Search</td>
<td>45</td>
</tr>
<tr>
<td>Deleting and Moving Pages</td>
<td>46</td>
</tr>
<tr>
<td>Deleting and Moving Pages with Thumbnails</td>
<td>46</td>
</tr>
<tr>
<td>Splitting and Merging PDF Documents</td>
<td>47</td>
</tr>
<tr>
<td>Splitting PDF Documents</td>
<td>47</td>
</tr>
<tr>
<td>Merging PDF Documents</td>
<td>48</td>
</tr>
<tr>
<td>Attachments</td>
<td>49</td>
</tr>
<tr>
<td>Editing Modes</td>
<td>50</td>
</tr>
<tr>
<td>Hand Tool. Context menu</td>
<td>50</td>
</tr>
<tr>
<td>Creating and Modifying Bookmarks</td>
<td>51</td>
</tr>
<tr>
<td>Editing Objects</td>
<td>53</td>
</tr>
<tr>
<td>Undo and Redo</td>
<td>53</td>
</tr>
<tr>
<td>Aligning Objects</td>
<td>53</td>
</tr>
<tr>
<td>Objects Copying and Pasting</td>
<td>54</td>
</tr>
<tr>
<td>Paste to Multiple Pages</td>
<td>55</td>
</tr>
<tr>
<td>Moving objects</td>
<td>55</td>
</tr>
<tr>
<td>Objects Rotation</td>
<td>56</td>
</tr>
<tr>
<td>Objects Deleting</td>
<td>56</td>
</tr>
<tr>
<td>Transformation Matrix</td>
<td>57</td>
</tr>
<tr>
<td>Clipping Path</td>
<td>62</td>
</tr>
<tr>
<td>Vector Images</td>
<td>62</td>
</tr>
<tr>
<td>Creating Vector Images</td>
<td>62</td>
</tr>
<tr>
<td>Copying and Pasting Vector Images</td>
<td>63</td>
</tr>
<tr>
<td>Modifying Vector Images</td>
<td>63</td>
</tr>
<tr>
<td>Text</td>
<td>66</td>
</tr>
<tr>
<td>Adding Text to Document</td>
<td>66</td>
</tr>
<tr>
<td>Text Copying and Pasting</td>
<td>66</td>
</tr>
<tr>
<td>Text Modifying</td>
<td>67</td>
</tr>
<tr>
<td>Text Rotation</td>
<td>69</td>
</tr>
<tr>
<td>Possible Issues with Text</td>
<td>70</td>
</tr>
</tbody>
</table>
Setting Different Attributes in one Text Object ................................................................. 70
Impossible to edit text ........................................................................................................ 70
Comments ............................................................................................................................. 71
Adding Comments to Document .......................................................................................... 71
Modifying Comments ........................................................................................................... 72
Export and Import Comments Data ..................................................................................... 73
Forms .................................................................................................................................... 75
Filling Interactive Forms ....................................................................................................... 75
PDF Forms Properties. Objects Inspector ............................................................................ 76
  Geometry Tab ...................................................................................................................... 76
  General Tab ......................................................................................................................... 76
  Appearance Tab .................................................................................................................. 77
  Options Tab ......................................................................................................................... 77
  Actions tab ............................................................................................................................ 78
Aligning Interactive PDF forms ............................................................................................ 79
Creating and Modifying Interactive PDF Forms .................................................................... 79
  Link ...................................................................................................................................... 79
  Push Button ......................................................................................................................... 80
  Check Box ............................................................................................................................ 81
  Radio Button ......................................................................................................................... 81
  List Box ................................................................................................................................ 82
  Combo Box ............................................................................................................................ 83
  Edit Box ................................................................................................................................. 83
Export and Import Forms Data .............................................................................................. 84
Digital Signature .................................................................................................................... 85
  Creating Signature and Signing .......................................................................................... 85
  Digital Signature Validation ............................................................................................... 86
Print ....................................................................................................................................... 88
  PDF Document Printing .................................................................................................... 88
  Print Preview ......................................................................................................................... 88
Hotkeys ................................................................................................................................. 90
Virtual PDF Printer ................................................................................................................. 93
License Agreement .................................................................................................................. 95
Introduction

Overview

Master PDF Editor is simple in use but effective application for work with PDF files. Its features enable you to create, edit, view, encrypt, sign, and print interactive PDF documents with just a couple mouse clicks. Applications features include full PDF files support, import/export of PDF pages to images of different formats, XPS conversion to PDF and 128-bit encryption. You can also add different control elements such as buttons, text fields, flags and many other. Each control element can have event handlers assigned for predefined user actions, such as click, scroll, or selection. Your work will become even simpler than ever before with powerful comment tools like Sticky Note and Stamp.

Master PDF Editor provides extensive functionality for work with PDF files, which makes it one of the best PDF editing software:

- Create new PDF file or edit existing.
- Change any element in PDF file.
- Add or edit bookmarks in PDF file.
- Encrypt/protect PDF files with 128-bit key.
- Convert XPS files to PDF format.
- Add control elements like buttons, flags, lists etc to your PDF files.
- Import/export PDF pages to/from BMP, JPG, PNG, and SVG/TIFF formats.
- Split and merge PDF files.
- JavaScript support.
- XFA dynamic forms support.
- Forms values validation and calculation.
- Editing PDF text, any forms, images, and pages.
- Fast and simple PDF forms filling.
- Signing PDF documents with digital signature.
- Changing font attributes (size, family, color etc).
System requirements

**Microsoft Windows:**
XP (Service Pack 3), 2003, 2008, Vista, 7, 8, 10 (32 & 64 bit)

**Linux:**
For distribution with Qt4: Qt 4.62 or higher, glibc 2.12 or higher (32 & 64 bit)
For distribution with Qt5: Qt 5.21 or higher, glibc 2.14 or higher (64 bit only)

**Mac OS X:**
Version 10.7.5 or higher.
Installing Master PDF Editor

After you've completed downloading installer, launch installation by double-clicking installer icon with mouse.

When it's launched you will see a greeting window. Press Next > button.
After you've read **License Agreement** (p.95) *choose according item and click Next >.*

If you do not agree with any of the items of the Agreement click **Cancel**.

Click **Install** button in the next dialog window to install the application.

Status bar shows installation progress. This should take less than a minute.

After Master PDF Editor installation you'll see dialog window, informing you about completion. Press **Finish** button and Master PDF Editor will be launched on your PC.
If you do not want to use the application right after installation, disable the checkbox.

«Silent» Installation

After you've read License Agreement and agreed to all its items, you can use "Silent Installation", which neither pops up any dialog window nor asks for agreement on installation stages.

Parameters for "Silent Installation" launch in command window:

Installation file path/MasterPDFEditor-setup.exe/verysilent

Technical Support

Please, contact us by support@code-industry.net email if you have any questions concerning software purchase, functionality, Master PDF Editor licensing. Likewise, do not hesitate to contact if you have found any issues or have any suggestions about application improvement.

We are always eager to hear from you. If you have any issues or questions, please, make sure you use last software version and cannot find required information in User Manual before contacting us.
Activation

You may use Master PDF Editor for free for reading, filling PDF forms and printing documents. The only limitation of unregistered version is watermarks on saved documents.

Linux version is not limited in this way, so you can freely use unregistered application for work on home PC and in non-commercial purposes like education.

In order to activate the application you have to purchase a license. This will grant you registration key for Master PD Editor activation.

One registration key can be used for Master PDF Editor activation on work station and home PC or laptop with any of the supported OS (Window, Linux or Mac OS X).

Follow this link for purchase:

https://code-industry.net/purchase/

All licenses are valid for unlimited term for the software version they were purchased for. Besides, our clients are provided with technical support and free updates for a year after purchase date. After this term registered users can renew the license by purchasing new version for 50% of the actual price, which automatically gives another year of support and updates. Contact us with technical support contact form on our Contact Us page or by email address sales@code-industry.net.

Please, make sure to inform Order ID or email address you used when purchasing, if you contact us about license renewal!
**Online Activation**

You can use either online or offline activation. For online Master PDF Editor activation your computer has to be connected to the internet. If you are already connected, preform following actions:

Double click Master PDF Editor icon on desktop and choose Help -> Register... in main menu.

You'll see following screen:

![Registration Info](image)

Copy registration code you received before and paste it into corresponding field (look at screenshot). Then click **Activate** button. Application activation allows you to use all Master PDF Editor functions without watermarks in output file.

After completing activation you will receive free updates for your Master PDF Editor copy within 1 year.

In order to find out are there any updates available for you, choose **Help -> Check for Update**.
Offline Activation

In order to activate Master PDF Editor in autonomous mode, perform following actions:

Double click Master PDF Editor icon on your desktop and choose Help -> Register... Set Offline Activation checkbox on. Activation Code field will appear near Registration Code field. System will also generate unique identifier for you (ID is selected on screenshot below). Please, copy-paste to e-mail and send ID and Registration Code to our e-mail address support@code-industry.net.

Please, inform your Order ID or e-mail address you used for purchasing! Letter without this information will be ignored!

After you receive the response with activation code, do not type it in manually. Instead, copy-paste it to Activation Code field, also paste registration code to Registration Code field and then click Activate.
License Deactivation

Use that function if you want to activate Master PDF Editor on another PC.

After that you can activate Master PDF Editor on another PC with your registration code.

Choose **Help -> Register...** and click **Deactivate** button
**Workspace**

Main menu and toolbars can be found in the top of the window. Toolbars contain control elements for organizing files.

**Navigation Area** in the left of the screen allows to move through the document. Central part of the screen is occupied by the **Document Area**. It contains PDF file user is currently working with. You can switch current document by clicking required tab in the top of that area. **Object Inspector** is located on the right, you can use it to modify objects' properties.

Bottom part of the workspace contains the **Status Line**.

Width of **Navigation Area** and **Object Inspector** can be changed by dragging their borders with a mouse.
Main Menu

File Menu
Common file operations for XPS and PDF can be found in File menu. They include:

• **New (Ctrl+N)** Create new file.

• **Open (Ctrl+O)** Opens existing PDF or XPS file.

• **Recent Files** View files which were opened and/or changed recently. You can also clear that list by choosing *Empty recent files list.*

You can open multiple documents in same Master PDF Editor at a time. When multiple files opened you can easily choose required file by clicking corresponding tab below the toolbar.

• **Save (Ctrl+S)** Save current file.

• **Save As... (Ctrl+Shift+S)** Save current file with new name.

• **Save Optimized As... (Ctrl+Alt+S)** Optimisation allows to reduce size of images in PDF file. Using all or only some of the optimization parameters depends on planned file usage and its desired properties.

  - **Export PDF to Image** *(p. 41)* Save current document as image in one of the following formats: BMP, JPG, PNG, TIFF.

  - **Print (Ctrl+P)** Print current file. This will show default print dialog, where you can set printing properties.

  - **Print Preview (Ctrl+Shift+P)** Open additional dialog window with additional printing options.

  - **Document Properties** *(p. 32)* *(Ctrl+D)* Current document properties.

  - **Close** Close current document.

  - **Quit** Quit the application.

Edit Menu
Master PDF Editor supports a set of common operations on PDF documents. They are
accessible via Edit menu.

- **Cut (Ctrl+X)** Cut selected element and puts it into clipboard.
- **Copy (Ctrl+C)** Copy selected element and puts it into clipboard.
- **Paste (Ctrl+V)** Paste cut/copied element from the clipboard.
- **Delete (Del)** Delete selected element.
- **Paste to Multiple Pages** (стр. 55)— Paste selected object or text to multiple pages at once.
- **Select All (Ctrl+A)** Select all elements on the current page.
- **Undo (Ctrl+Z)** Undo previous action.
- **Redo (Ctrl+Y)** Redo last undone action.
- **Send to Back (Ctrl+-)** Move selected element to the background.
- **Bring to Front (Ctrl++)** Move selected element to the foreground.
- **Align Objects** Automatically move or align selected objects. There are 4 types of alignment: Left, Right, Top and Bottom.
- **Set Fit to Page** Set width of the current document to match page size.

**View Menu**

Master PDF Editor supports a set of general operations for PDF document view. They can be accessed via View menu.

- **First Page (Home), Previous Page (PgUp), Next Page (PgDown), Last Page (End):** Move to the corresponding page.
- **Zoom In (Ctrl++)** Increase current zoom.
- **Actual Size** Display content at 100% scale.
- **Zoom Out (Ctrl+-)** Decrease current zoom.
- **Fit Page** Scale page to fit window in height.
- **Fit Width** Scale page to fit window in width.
- **Facing Pages** Display two pages at once for multipage PDF files (with 2 or more pages).
- **Enlarge Page Thumbnails** Enlarge page thumbnails.
- **Reduce Page Thumbnails** Reduce page thumbnails.
• Search (Ctrl+F) Search for symbol sequences in a document.

• **Object Inspector** (p. 22) Show/hide Object Inspector.

• **Toolbars** Allow to show/hide one of six available toolbars.

• **Status Bar** Hide/show status bar in the bottom of the window.

**Insert Menu**

Master PDF Editor allows to add different objects to PDF files with Insert menu.

Every object has unique parameters which can be changed with **Object Inspector** (p. 22).

• **Text**(Ctrl+T) — add text to your document.

• **Image**(Ctrl+I) — add image to your document.

• **Line** — draw straight line.

• **Rectangle** — draw rectangle.

• **Ellipse** — draw ellipse.

• **Pencil** — use to draw lines by hand.

Creation and editing of vector images described in **Vector Images** (p. 62).

**Comments Menu**

Comments are used for text reviewing or suggesting possible changes in PDF documents. They are not editing tools itselft, since their use doesn't alter source file content.

Comment tools:

• **Add Sticky Note** — Note is one of the most basic comment tools. Mouse click a place where you want to locate your note and insert your comment. Author's name will be automatically included into the header. Other users may answer notes.

• **Text highlight** — Mark important parts of text for later usage.

• **Text strikethrough** — Text selection with strikethrough.

• **Text underline** — For text underlining.

• **Data Export** — Export comments with records to separate fbf file.

• **Data Import** — Add exported and saved to fbf file comments to current PDF file.
Creation and edition of Comments described in Comments section (p. 71).

**Forms Menu**

- **Select Forms** — Select all forms in the document.
- **Reset Forms** — Reset all form values in the document. Values will be set to default or empty if default is not specified.
- **Edit Forms** (Alt+3) — Tool for selecting and editing PDF forms only.
- **Link** — Add hyperlink.
- **Edit Box** — Create field for text input. For example, name, date, phone number etc.
- **Check Box** — Create check box, which has two states: disabled or enabled. When enabled, it has a check mark inside of it.
- **Radio Button** — Create a switch, which allows to choose one option of a limited set of mutual exclusive options.
- **Combo box** — Create a list, which allows to choose single item or input a value.
- **List box** — Create a list, which allows to choose single item or input a value.
- **Button** — Create a button, which can launch any action.
- **Digital Signature** (crp. 85) — Apply digital signature to a document.

**Document Menu**

**Insert Blank Pages** Display a dialog window where you can choose position and number of new pages and their parameters (size, orientation, field contents size).

**Delete Pages** (Alt+Del) Remove current or selected pages. You can also use a panel with thumbnails to select and delete pages.

**Move Pages** Display a dialog window where you can set specific pages to move and their destination. Can be used with thumbnails panel, which allows to choose pages with mouse. You can use **Shift** key with left mouse button to select a continuous group of pages. You can choose any group and number of pages if holding **Ctrl** key.

**Crop Page** (Ctrl+K) Crop page content with mouse.

**Page Layout** Display a window which allows to set page layout (width, height in pixels, inches or mm) and content size if user needs to display only part of a page (left, right, top and bottom fields).
**Rotate Pages** (Ctrl + R) Rotate current or selected pages by 90, 180 or 270 degrees.

**Extract Pages** Specify file name to export pages to (you can also use **Browse** button) and numbers of pages to export. It is possible to export all the pages to same file or create separate file for each page. You can also export bookmarks.

**Insert Pages** Import pages from specific PDF file (use **Browse** button), specify location for import in the current document and numbers of pages for import. Allows to import bookmarks as well.

**Document Actions** Creation and modifying of JavaScript functions to be executed on specific document actions, such as: **Document Did Print, Document Did Save, Document Will Close, Document Will Print, Document Will Save**

**Document JavaScript** Creation and modifying of JavaScript code to be executed on document opening. Global JavaScript functions and variables called from local events are also defined here.

**JavaScript Console** allows to execute any JavaScript code or get debug JavaScript output of current document.

**Page Properties** Setting tab order for PDF forms in Hand Tool mode. Available options:

*Use Row Order, Use Column Order, Use Document Structure, Unspecified.*

Creating and modifying JavaScript code to be executed on page opening and closing.

**Tools Menu**

**Edit Document** (Alt+1) — Select PDF objects to move, resize or delete them or change their properties.

**Edit Text** (Alt+2) — Text editing only.

**Edit Forms** (Alt+3) — Forms selection and editing.

**Hand Tool** (Alt+4) - Move pages, select text and open links.

**Select Text** (Alt+5) — Text selection only.

Use **Preferences** item for application settings. Description at p. 23.

**Help Menu**

• **Contents** Help contents.

• **Home Page** Open main Master PDF Editor page.
• **Register… Activation** (p. 10) Master PDF Editor.

• **Check for updates** Check for Master PDF Editor updates available for you.

• **About** View Master PDF Editor information. Use to see registration and version number.

### Context Menu

You can see a Context menu if you right-click on any workspace object. It shows a list of commands for that specific object or area.

### Toolbars

Toolbars contain icons for different tools of each menu.

Master PDF Editor has 6 toolbars:

- **General**;
- **Edit**;
- **View**;
- **Search**;
- **Tools**;
- **Forms**;
- **Comments**.
- **Find**.

You can see a tool description if you place a cursor over its icon.

Perform following actions to show or hide toolbar:

- Press View tab in Main menu and choose Toolbars item. Check items with required toolbars. They will appear on the screen. You can uncheck items to remove toolbars.
- Right click a space with no buttons on a toolbar or main menu and check/uncheck items for required panels.

### Document Tab

You can switch between files when working on multiple PDF files in one Master PDF Editor instance.
Pop Up Message

Pop up message can be seen only if current PDF document contains forms or is protected by password.

When opening file with PDF forms, pop up message will inform you about that and provide a button. You can select all PDF forms of the document by clicking that button.

If the document is password protected from editing, when you choose Edit Document pop up message will inform you that the document is encrypted and you don't have permission to edit it. You can click Change button in the message to change owner's password and remove restrictions.

Status Bar

Status bar is a part of the workspace. It displays:

- When Edit Document, Edit Text or Edit Forms is on, you can see number of current page, total number of pages, width and height of the page in pixels and number of objects on the current page.
- Object type and some other info when an object is selected.
- When Hand Tool or Select Text is on, you can see number of current page and total number of pages.

When opening PDF files you can see also Status bar by default. Main menu item in View submenu allows you to show it or hide.

当他 hovering a tool with mouse cursor you can see its description in the Status bar.

Navigation Area

Navigation area is a window with 4 tabs:

- Pages — displays pages thumbnails;
- Bookmarks — lists all bookmarks in the current document;
- Attachments — allows to insert, edit and remove attachments;
- Search — searches text case-sensitively in the current document including comments.

You can change width of Navigation area by moving its edge with mouse.
**Document Area**

*Document Area* displays PDF file users works with currently.

**Object Inspector**

Every object in PDF document has unique parameters, which can be changed by Object Inspector. It is good tool for both changing objects' parameters and controlling event, which objects react to.

Open Object Inspector by clicking its tab in the right part of the workspace. Switch mode to Edit Tool (you can do that by clicking *Edit Document* button on the toolbar) and choose any object. Parameters of the object will be displayed in **Object Inspector**. Now they can be easily changed as you require.

You can also open *Object Inspector* with context menu. In edit mode right click selected object and choose *Parameters* item.
Preferences

In order to open settings window, choose **Tools > Preferences** in Main menu.

In Mac OS X it is Master PDF Editor > Preferences…

System Tab

- **Create backup file.** Master PDF Editor creates backup copy when saving the document. Backup is created only once.
- **Destination choice for «Save As…» documents.** Choose folder to open when saving file with «Save As…».
- **Restore last session when application starts.** Master PDF Editor saves and restores all opened documents and panels location when relaunching program.
- **Restore last view settings when reopening.** If enabled, all view settings are restored when reopening the document.
- **Open documents as new tabs in the same window (relaunch required).** If disabled, each PDF
file will be opened as new application instance. Option is absent in Mac OS, because there it is set in general system preferences.

- **Enable scroll wheel zooming.** Enables/disabled zoom control with mouse wheel or touchpad when Ctrl is pressed.

**Forms Tab**

- **Highlight color.** Set color for highlighted PDF forms.
- **Required field highlight color.** Set color for highlighted required PDF forms.
- **Always hide document message bar.** Always hide pop up message.
- Appearance setting for created PDF forms.

Use *Forms > Highlight Forms (Ctrl + H)* for forms selection or forms selection reset. (For Mac OS X: *Cmd+H)*.
Edit Tab

- **Time before a move or resize starts.** Time after object selection before it can be dragged or resized. Prevents random mouse dragging.

- **Default font.** Set default font settings for application.

- **Automatically change font when editing text.** Automatic replacement of PDF font for system TTF font when editing text. Automatic replacement happens only if the application finds similar font in the system.
JavaScript

- **Enable JavaScript.** Enables or disables JavaScript usage in PDF files.
- **Show errors and messages in console.** Show errors and messages in console. Outputs all Javascript messages to the console after executing document’s code. JavaScript console can be opened in **Document-> JavaScript Console**
Comments

Default properties for comments.

- **Author.** Default name is system user name. You can specify any name to set as author when creating comments.

- **Note.** Note settings.
  - **Type.** Choose type of note appearance: comment, circle, check mark.
  - **Opacity.** Opacity of the note.
  - **Color.** Color of the note.

In the right part of the window you can set preferences for following comments: text highlight, text underlining, text strikethrough. To do this choose comment type in the dropdown list and set its preferences. Then choose next type and set its preferences too.

- **Highlight Text/Striketrhough Text/Underline Text.** Comment type selection.
  - **Opacity.** Opacity of the comment lines.
  - **Color.** Color of the comment lines.
  - **Line width.** Width of underline and strikethrough lines.

- **Pop-up Opacity.** Opacity setting of pop-up form for all comment types.
Display Tab

- **Default Layout and Zoom.** Page settings for newly opened and created PDF files.

- **Always show Object Inspector.** Default setting for Object Inspector on launch. (Will be enabled for newly opened document if **Restore last view settings when reopening.** is not enabled in **System** tab.)

- **Smooth text and images.** Choose objects to apply anti-aliasing.

- **Replace Document Colors.** If enabled, provides possibility to change font and background color in the document.

- **Resolution:**
  - **System PPI.** Uses system PPI setting to display document on the monitor.
  - **Custom resolution.** Allows to set monitor resolution manually if it's required for your work or Master PDF Editor incorrectly identified it.

Application relaunch is required for settings to take effect.
Appearance

Tab is available for Windows and Linux only.

- **Theme.** Enable to switch color theme to **Fusion Dark Style**.

- **Icons in menus.** Show/hide icons in Main menu. This option doesn’t work in some Linux desktop environments, for example Unity.

Note: Application relaunch is required for settings to take effect.
Language Tab

On this tab you can change interface language for Master PDF Editor.

Application relaunch is required for settings to take effect.
Update

Set frequency for automatic update check. You can set to check never, weekly or monthly.

In order to check for updates manually choose Help > Check for update in Main menu.
**Document Properties**

Choose **File > Properties** in Main menu or press **Ctrl + D**.

**Document properties** window contains four tabs: Document Info, Security, Initial View and Fonts. Its appearance can be seen below.

**Document Info**

**Document Info** tab allows to specify following properties: Title, Subject, Author, Creator and Producer. User also can specify some keywords corresponding to the document's content in the bottom field.
Document Security

Access to PDF can be limited with password. For security purposes you also can disable some functions, for example printing or editing. However, it is impossible to prohibit saving PDF copies. It is ensured, that copies will have same limitations as original PDF file.

Click Change button to set password and edit items in Permissions group. Additional window will appear, it allows to set passwords for the document.

Two kinds of passwords can be used for PDF encryption:

- **Document open password.** A password required to open the document.

- **Permissions password.** If some functions are disabled for the document (Permissions list), a permissions password for access rights modification must be set. Document open password is not required.

If PDF file is protected with passwords of both kinds, it can be opened with any of the passwords. But user has to enter Permissions password to access Permissions. It is advised to set both passwords to establish better security.
• **Print the document.** Printing is possible with 150 dpi or lower resolution.

• **Print a high resolution version of the document.** Printing is possible with any resolutions.

• **Content copying for accessibility.** Allows users to select and copy document text.

• **Extract the content of the document.** Allows to copy text and other objects.

• **Fill in existing form or signature fields.** Users may fill and sign form fields. Doesn't allow to add comments and create new form fields.

• **Commenting.** Filling form fields and digital signature signing. Users may sign with digital signature, leave their comments and fill forms. However, users cannot move objects on the page or create new form fields.

• **Manage pages and bookmarks.** Allows to insert, remove and rotate pages, create bookmarks and thumbnails.

• **Modify document.** Allows to change document content (text, images etc)
**Initial View**

Initial View tab provides means to set view of the workspace of the document for any PDF viewer used to open it.

- **Page Mode.** Choose required page view mode from the list.
- **Open on Page.** Specify number of first page for view.
Font

Fonts tab provides a list of all fonts used in the document.

![Font screenshot](image.png)
Opening and Saving Files

Master PDF Editor is fully compatible with PDF specification 1.7 and also supports files with dynamic XFA forms, which allows the application to open and view any files created in other PDF editors while saving their settings.

Opening PDF Files

PDF document can be opened:

▪ From Master PDF Editor application.
▪ From email client.
▪ From file system.
▪ From the network with web browser after downloading file to local PC.

Initial view of PDF document depends on its properties, set by owner. It can be opened with predefined scale on specific page.

Opening Documents

Preform any of the following actions to open file in Master PDF Editor:

▪ Double click PDF file icon in the file system.
▪ Choose File > Open in Main menu or press Open File button on the toolbar (or use Ctrl+O shortcut). In the Open File dialog window choose file name and press Open. As a rule, PDF documents have .pdf extension.
▪ Open Master PDF Editor window and drag PDF file into it.

Opening Protected PDF Document

If you received PDF document which is protected from opening, entering password is required to work with it. Some protected documents have limitations, disabling printing, editing, copying etc. Such document can be opened without a password.

It is required to enter Permissions password to access limited functions.
More detailed information is provided in Document Properties section, Document Security (p. 33).

**Recently Opened Documents**

To view recently opened documents select:

- File > Recent files.
- Or click dropdown list ▼ icon to the left of Open file button on the toolbar.

To clear history of recently used files select File > Recent files > Empty recent files list.

**Saving PDF Files**

Master PDF Editor allows to save PDF documents with comments, records in form fields and digital signatures. Users may modify files, if document owner hadn't set certain limitations. All additional prohibitions for using and saving files may be viewed in menu File > Document Properties, Security tab.

In order to save changes in the current file, select File > Save in the Main menu or press Save button on the toolbar. You can also use Ctrl+S keyboard shortcut.

To save PDF file copy, choose File > Save As… in Main menu or press Save As… button on the toolbar. You can also use Ctrl+Shift+S keyboard shortcut.

To export PDF into variety of image formats choose File > Export to > Images.

Repeated saving of PDF file with digital signature invalidates the signature.
Optimisation and Saving

Optimisation allows to reduce PDF files size. Specific parameters of saved file depend on later usage of the file and properties required for the resulting document.

Please note that optimising file with some compression methods may damage images, which will lead to poor printing quality.

To optimise and save PDF file choose **File > Save Optimized As...** in main menu or use **Ctrl+Alt+S** shortcut.

This will open a window, which allows to set following preferences for color and black and white images.

Set following preferences if required.

- **DPI** — Reduce image resolution to decrease file size.

Resolution cannot be further reduced for images with 16x16 DPI.
• **Compression** — Decreasing file size with different algorithms. **JPEG** compression yields best results for photos with smooth color gradients. **ZIP** is best choice for drawins and patterns with big areas of same color. **JBIG2** is applied for black and white pages. If right algorithm is chosen, compression is conducted without losses, and lower quality images are better compressed. Images with text can be better compressed than with **CCITT Group 4** algorithm, but compression takes more time. Currently Master PDF Editor uses lossless compression. **CCITT Group 4** is also applied for pages with black and white images and is the fastest lossless compression algorithm.

• **Quality** - Available only for JPEG format. JPEG compression is always done with loss of image quality, since some pixel data are removed without possibility of restoring during compression. Color images are better compressed with lossy JPEG compression algorithm. Quality level around 75-95 has best size-quality ratio. Quality 60-70 yields small picture with acceptable quality. 30-50 quality percentage is optimal when small file size is important and image quality is not prioritised.

Grayscale images are compressed with **CCITT**, **JBIG2** and **ZIP** without losses.
**Export PDF to Image**

Master PDF Editor allows to export PDF documents into image formats and then reopen them and use in another applications.

When saving PDF file in image format, each page is saved in separate file. The only exception is export to TIFF format. When exporting to TIFF, user can choose whether to save whole PDF file into one file or each page separately.

To export PDF file to image, choose **File > Export To > Images**.

This will open a dialog window with following settings.

- **File Name.** Specify name and path for document export destination file (you can use button).
- **Page Range.** Choose pages to export.
- **Format.** Choose compression format for output image (BMP, PNG, JPEG, TIFF).
  - **MultiPage.** All PDF document pages will be exported into single file if enabled (available only when exporting to TIFF),
  - **Transparent.** If enabled, exported pages will have transparent background (available only when exporting to PNG).
- **Size.** Specify DPI.
Press **Export** button, to convert PDF document to image, then click OK in the next window. Export operation will be cancelled, if cancel button is pressed.

**Closing**

If you work with multiple documents and you need to close current PDF file, press Close button on the tab. You can also choose **File > Close** in main menu. Press **Close** button in Master PDF Editor window to close all documents.

If you work with single document, just click **Close** button in Master PDF Editor window.
PDF Files View

Setting View Mode

Master PDF Editor offers a variety of tools, which can help you set PDF documents display mode and scale. To access these tools, open View menu or use tool buttons on the toolbar.

- **Zoom In**/**Zoom Out** *(Ctrl++)/(Ctrl+-)* — zoom in/out. You can also specify scale in special field on the toolbar 112%.

You can Zoom In/Out by holding Ctrl key and scrolling mouse wheel.

- **Actual Size** — set display scale according to the actual document size.
- **Fit Page** — scale to display whole page in the document area.
- **Fit Width** — set scale to make page fill entire width of the document area.
- **Facing Pages** — display two pages in document area at once (for multipage PDF files).
- **Replace Document Colors** — change document colors to ones set in Tools>Settings>Display.
- **Rotate 90 degrees Clockwise**/**Rotate 90 degrees Counterclockwise** — rotate pages clockwise/counter clockwise.

Document Navigation

Move to Specific Page

To navigate the document choose View > (First Page, Last Page, Previous Page and Next Page) or press corresponding button on the keyboard: Home, End, PgUp, PgDown.

Toolbar contains means for moving to next or previous page. For fast transition to specific page specify its number in the according field on the toolbar.
**Transition with Bookmarks**

Bookmark is a kind of link, which allows to move to different document sections. Bookmarks are displayed as tree in the **Navigation Area**.

To use bookmarks to move to specific document section, press **Bookmark** tab on the **Navigation Panel** in the left part of the workspace. Then choose required bookmark. You can expand its content with + icon or minimize with – icon.

With bookmarks you can not just go to required document section, but preform another action: open another file, a page, a web link, reset forms, show or hide forms, launch JavaScript.

**Transition with Page Thumbnails**

You can use page thumbnails to quickly move to the required page. Thumbnails are displayed at **Pages** tab in **Navigation Area**.

For better comfort and experience you can change thumbnails size and Navigation Area size. Right click a thumbnail and choose **Enlarge Page Thumbnails** or **Reduce Page Thumbnails** in the context menu, or use same commands in Main menu **View** tab.

If you remove, copy or move thumbnail, same action will be applied to the corresponding page.
Text Search

With Master PDF Editor you can search and highlight required information. Search is conducted in both text and hidden content: comments, bookmarks etc. Search results are displayed as a list. Words found in main document text are highlighted.

For search choose Search tab in Navigation Area (or use Ctrl+F hotkey). Set search criteria and insert text into field, then press Enter.

Search can be conducted with following criteria:

- **Case Sensitive.** Text will be searched with case matching. For example, if you are looking for word “text”, words “Text” and “TEXT” won’t be matched.

- **Include Comments.** Search will be conducted not only in main document text, but in comments too.

You can move through the list with mouse or using keyboard arrows and Enter key to select search result.

Click the cross icon to clear search field.

Window size can be modified with mouse by dragging window's right border to required position.

You can also use special field on toolbar for search. Set search criteria, insert text and press Enter key. Found words will be selected, you can move between them with Enter or F3 buttons.
Deleting and Moving Pages

With Master PDF Editor you can remove or move one or multiple pages. To delete page(s) open Pages tab of Navigation Area. Right click a thumbnail and choose Delete Pages item in the context menu. This will open a Delete Pages dialog window. You can also open it with Alt+Del, or Alt+Fn+Del in Mac.

- **Pages** — enable if required to delete several pages. List pages to delete separated with commas, or pages range. Press Ok to delete pages.
- **Current page** — enabled by default. Click Ok if you need to remove only current page.
- **Pages From — To** — enable to set specific pages range for removal.

Please note, that Delete Pages command can't be undone. Removed pages can't be restored.

Deleting and Moving Pages with Thumbnails

Pages can be removed with thumbnails. Select one or multiple page thumbnails in Pages tab of the Navigation Area. To select several successive thumbnails, select the first one and then hold Shift key and left click the last one. To select any set of thumbnails, hold Ctrl button and left click required ones.

After selecting right click a thumbnail and choose Delete Pages item in context menu. Then you'll see a pop up window with deletion properties. If multiple pages were selected, their numbers will be filled in the corresponding field.

To move page(s), select required ones as described above. Then click them and drag to
Deleting and Moving Pages

Moving pages can’t be undone.

Splitting and Merging PDF Documents

While the document is being developed, its content may require drastic changes. It can be assembled into single document out of several sections. Some pages, paragraphs and sections may be modified, rewritten, moved or copied into separate document. With Master PDF Editor you can preform these tasks with great ease.

Splitting PDF Documents

This function allows to split multipage document into several lesser documents or split it into separate pages.

To extract pages from the document choose Document > Extract pages… (Ctrl+Shift+E) menu item. Extract Pages dialog window will pop up.

- **File name** — choose file path and name to save extracted pages. Use Browse button to access file structure.

By default, extracted pages are put into new document named Экспорт страниц[source document name]_[page name].

47
Splitting and Merging PDF Documents

- **Pages range** — specify pages to extract: *current page, all pages* or a specific set of *pages* (with specified numbers or ranges).

- **Extract pages as a single file** — if enabled, all pages will be extracted into single file. Disable to create separate PDF file for each extracted page.

- **Export bookmarks** - if enabled, bookmarks of PDF document will be exported with pages.

PDF document owner may restrict pages extraction. Restrictions for current file may be viewed in menu **File > Properties, Security** tab.

### Merging PDF Documents

This function allows to merge and systematize multiple separate PDF documents in single file.

To insert pages into document choose **Document > Insert Pages…**(*Ctrl*+*Shift*+*I*) menu item. **Insert Pages** dialog window will pop up.

- **Position** — choose one of pages insertion options: *before page* (page number specified), *after page* (page number specified), *before first page*, *after first page*.
• **File name** — choose file name and path to insert pages from it. Use **Browse** button to find the file. Also specify numbers of pages to insert into current document.

• **Import bookmarks** — enable to import bookmarks from PDF document.

**Attachments**

PDF document may include files of any format as attachments. Attached files are stored within document they are attached too. When moving document to another folder, all attached files are moved with it.

Use context menu commands for work with attached files. The context menu can be opened with right click in any place of **Attachments** tab in **Navigation Area**.

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
<th>Size</th>
</tr>
</thead>
<tbody>
<tr>
<td>untitled.pdf</td>
<td>Description</td>
<td>1 KB</td>
</tr>
</tbody>
</table>

• **Insert** — attach a file to PDF document. If chosen, a dialog window will pop up, where you can choose required file. File name will be displayed in Attachments tab. Double click in **Description** field allows you to specify text for attached file identification.

• **Remove** — remove file from attachments

• **Save as** — save attached file on your drive

• **Open** — open attached file in default application for this type of files
Editing Modes

Master PDF Editor is a convenient tool to modify PDF documents in any way. The application supports copying, pasting, removing, editing and other operations on objects. It also enables you to change properties of text, vector and raster images, PDF forms and other objects.

Below is a list of editing modes(tools) for different objects:

<table>
<thead>
<tr>
<th>Button</th>
<th>Tool</th>
<th>Shortcut</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>✉️</td>
<td>Edit Document</td>
<td>Alt+1</td>
<td>Mode for modifying any objects (text, images, comments, PDF forms).</td>
</tr>
<tr>
<td>🌐</td>
<td>Edit Text</td>
<td>Alt+2</td>
<td>Mode for text objects modification.</td>
</tr>
<tr>
<td>📝</td>
<td>Edit Forms</td>
<td>Alt+3</td>
<td>Mode for editing of text forms and annotations.</td>
</tr>
<tr>
<td>🖌️</td>
<td>Hand Tool</td>
<td>Alt+4</td>
<td>This mode is used to move through the pages, fill PDF forms, copy text, create and edit comments.</td>
</tr>
<tr>
<td>📉</td>
<td>Select Text</td>
<td>Alt+5</td>
<td>Mode for text selection for its further copying if it is hard to select the text with Hand Tool.</td>
</tr>
</tbody>
</table>

Hand Tool. Context menu

Context menu appears on right click on any object when Hand Tool 🖌️ is used. Depending on object kind following items are available:

- **Copy** — copy selected object/text to clipboard.
- **Select All** — select all text on current document page.
- **Add Sticky Note** — add sticky note for document review. Described in more details in Comments section (p. 71).
- **Highlight Text, Strikethrough Text, Underline Text** — a toolset for text commenting. More details on text commenting can be learned in Comments section (p. 71).
- **Add Bookmark** — see Creating and Modifying Bookmarks (p. 51)
Creating and Modifying Bookmarks

In Master PDF Editor you can create and edit bookmarks. Bookmarks are displayed as tree to Bookmarks tab in Navigation Area, they enable user to access specific document sections.

To create a bookmark, choose Hand Tool, select text you want to link with bookmark, then right click the text and choose Add Bookmark item in context menu.

You can also open Bookmarks tab in Navigation Area.

To create a root level bookmark, right click free area of Bookmarks tab (none of the other bookmarks must be selected). Choose Add Bookmark item in the context menu.

Dialog window Bookmark Properties will pop up.

- **Text** — specify name for created bookmark.
- **Appearance** — set font attributes for the bookmark
  - **Style** — text style. Options: plain, italic, bold, italic & bold.
  - **Color** — specify text color.
- **Goto a Page View** — if enabled, specify page where user will be redirected by created bookmark.
  - **Page Number** — specify page number for redirection. By default, set as number of page being viewed when creating bookmark.
  - **Set current position** — at this case saves not just a link to current page, but also its appearance on display including scale.
To create second level bookmark, right click root bookmark which should be set as parent, and choose **Add Bookmark** item in context menu.

Context menu will also provide following options:

- **Remove Bookmark** — removes selected bookmark.


Please note, bookmark removal cannot be undone.

- **Set Destination** — set current page as destination page for selected bookmark.

- **Bookmark Properties** — allows to edit bookmark properties.

**Actions** tab of the Bookmark Properties dialog window allows you to set event which will be fired on defined bookmark trigger. More detailed information can be seen at **Actions tab** p. 78).
**Editing Objects**

**Undo and Redo**

To undo last action:

- Choose Edit > **Undo** in Main menu.
- Press \( \text{Cancel} \) button on the toolbar.
- Press \( Ctrl + Z \).

Some actions cannot be undone with this command. For example, removal, moving, page rotation, File menu commands, bookmarks removal. If last action cannot be undone, **Cancel** button will be disabled (grey).

To redo last undone action:

- Choose **Edit -> Redo** in Main menu.
- Press \( \text{Redo} \) button on the toolbar.
- Press \( Ctrl + Y \).

**Aligning Objects**

To align objects enter edit mode by clicking **Edit Document** or **Edit Forms** button on the toolbar (or choose one of these items in Tools menu).

Select objects to align. You can do that by holding \( Ctrl \) key and successively clicking required objects. Last selected object will be considered active, and all selected objects will be aligned by it. However, if you have selected multiple objects at once, none will be active and objects will be aligned by page edge.

In **Edit > Align Objects** menu you can choose required alignment: *align by left edge, right edge, top or bottom edge*. Otherwise you can press required button on the toolbar:  

- **По левому краю**,  
- **По правому краю**,  
- **По верхнему краю**,  
- **По нижнему краю**.

To align objects you can also use settings in **Object Inspector Geometry** tab. It displays active object's settings. When selecting multiple objects at once, no active object will be chosen and
settings won’t be displayed in **Object Object Inspector**.

- **Left** — distance from left page border to the left border of the object.
- **Top** — distance from top page border to the top border of the object.
- **Coordinates** — sets offset when aligning objects with settings in *left* and *top* items. Coordinates can be *absolute* or *relative*.
  - **Relative** — when aligning objects using *top* and/or *left* items distance between objects remains same.
  - **Absolute** — when aligning all objects will be moved irregularly and will be positioned in coordinate point set in *top* and/or *left* items.
- **Maintain aspect ratio** — if enabled, object's aspect ratio isn't changed when its height and width are being modified.

**Example:** You have to move several objects and set them on defined distance from the page top edge.

Select multiple objects by holding Ctrl button and successively clicking them. In **coordinates** item set *relative*. Then input required distance in *top* item. All the objects will be moved to the top, and the distance between these objects will remain same.

**Objects Copying and Pasting**

To copy objects choose **Edit Document** tool. Select required object with left click and choose **Copy (Ctrl+C)** item in the **Edit** menu. To select multiple objects, hold Ctrl button and successively click them or select a group of objects with selection box by holding left mouse button. If you need to select all objects on the page, right click document page and choose **Select All** in the context menu.

To copy objects, choose **Copy (Ctrl + C)** in the **Edit** menu or press button on the toolbar. Otherwise right click selected object(s) and choose same command in the context menu. Selected objects will be stored in the clipboard. Now you can insert them into file in another program or place in Master PDF Editor document.

To insert objects into Master PDF Editor choose **Paste (Ctrl+V)** item in **Edit** menu or press button on the toolbar. You can also choose same command in the context menu. Pasted object
will be located on the same place as on the page it was copied from.

**Paste to Multiple Pages**

If required, user can insert copied objects to multiple pages at once. To do it, choose **Paste to Multiple Pages (Ctrl+Shift+V)** item in **Edit** menu. Set appropriate way of objects pasting in the pop up window.

- **Pages** — specify pages range to paste objects to.
- **All pages** — copy to all document pages.
- **Except current one** — if enabled, object won't be pasted to the current page.

**Moving objects**

Choose **Edit Document** tool to move objects. Choose one object or multiple objects or a group and drag them to required position with mouse. You can also move objects with keyboard arrows. Object(s) will be moved by 5 pixels with each arrow key press or by 1 pixel if **Ctrl** key is being held.

Objects can be moved only within current page. If you need to move object to another document page, use **Cut (Ctrl+X)** command in the **Edit** menu ( ![X](button on the toolbar) and **Paste (Ctrl + V)** command.

Sometimes it is required to move an object to the background or foreground. You can do it
with commands **Bring to Front, Send to Back** in the **Edit** menu ( ■ and □ buttons on the toolbar)

**Objects Rotation**

To rotate any object (text, raster or vector image, filled vector image) select it with **Edit Document** tool and open **Object Inspector, Geometry** tab. Click arrows in **Rotate** item or specify custom angle to rotate object by required angle.

Please note that clipping path won't be rotated if present. It should be removed. To do it, click **Remove** button in the **Clipping Path** tab.

**Objects Deleting**

To remove object(s), select it/them with **Edit Document** tool and press **Delete (Del)** in **Edit** menu or use same command in context menu. You can also click ⌂ button on the toolbar.
**Transformation Matrix**

Transformation matrix is used to calculate new coordinates of transformed object. By changing values of transformation matrix, it is possible to apply any transformations to objects (scaling, mirroring, rotating, moving etc). Any transformation preserves parallel lines.

Coordinates in PDF are described in 2-dimensional space. Point (x,y) in 2-d space can be described as [x y 1] in vector form. Constant third member of the vector (1) is required for simplicity of calculations with 3x3 matrices, described below.

Transformation between two coordinate systems is described as 3x3 matrix. In matrix form it looks as following:

\[
\begin{pmatrix}
a & b & 0 \\
c & d & 0 \\
e & f & 1 
\end{pmatrix}
\]

Coordinate transformations are written as cross product:

\[
[x' y' 1] = [x y 1] \times \begin{pmatrix}
a & b & 0 \\
c & d & 0 \\
e & f & 1 
\end{pmatrix}
\]

Since last row doesn't effect calculations result, it is omitted. Transformation coordinates are calculated as follows:

\[
x' = a x + c y + e
\]

\[
y' = b x + d y + f
\]

**Identity matrix**

Identity matrix is one which has a and d values equal to 1 and others equal to 0. This matrix is applied by default since it doesn't lead to any transformation. This is why it is base for further
transformations.

\[
\begin{bmatrix}
1 & 0 & 0 \\
0 & 1 & 0 \\
0 & 0 & 1
\end{bmatrix}
\]

**Scaling**

To increase object's horizontal or vertical size value a or d respectively must be changed, other values must stay as in identity matrix.

*Example:* To increase object's horizontal size, a value must equal to 2 and other values must stay as in identity matrix.

\[
\begin{bmatrix}
2 & 0 & 0 \\
0 & 1 & 0 \\
0 & 0 & 1
\end{bmatrix}
\]

Calculating new object's coordinates:

\[x' = 2x + 0y + 0; \quad x' = 2x;\]
\[y' = 0x + 1y + 0. \quad y' = y.\]

**Mirroring**

To get horizontal mirroring, it is required to set \( a = -1 \), or \( d = -1 \) for vertical mirroring. It is possible to change both \( a \) and \( d \) to get both horizontal and vertical mirroring.
Skew

To vertically or horizontally skew object value b or c respectively must be changed. b/-b is skew up/down, c/-c does left/right skew.

**Example:** To vertical skew object set \( b = 1 \).

\[
\begin{pmatrix}
1 & 1 & 0 \\
0 & 1 & 0 \\
0 & 0 & 1
\end{pmatrix}
\]

Calculating new object’s coordinates:

\[
x' = 1x + 0y + 0 \quad \Rightarrow \quad x' = x;
\]

\[
y' = 1x + 1y + 0 \quad \Rightarrow \quad y' = x + y.
\]

As a result, object is skewed by \( y \) coordinate only, which is increased by \( x \).
Rotate

Rotate is a combination of scale and skew, but in order to maintain initial object’s aspect ratio, transformation must be exactly calculated with the use of sin and cos.

\[
\begin{pmatrix}
\cos(\alpha) & \sin(\alpha) & 0 \\
-s\sin(\alpha) & \cos(\alpha) & 0 \\
0 & 0 & 1
\end{pmatrix}
\]

Object is rotated counter-clockwise, \( \alpha \) sets rotation angle in rad.

Moving

Moving is preformed by changing following values: \( e \) (for horizontal) and \( f \) (for vertical). Values are measured in pixels

Matrix is rarely directly used for movement, because this operation can be done with other methods, for example, dragging object with mouse in the workspace.

Since transformation matrix has just 6 elements available for modification, it is visually displayed in PDF as \([a\ b\ c\ d\ e\ f]\). Such matrix can represent any linear transformation from one coordinate system to another. Transformation matrices are formed following way:

- Movements are represented as \([1\ 0\ 0\ 1\ t_x\ t_y]\), где \( t_x \) и \( t_y \) — distances from coordinate axis horizontally and vertically correspondingly.
- Scaling is represented as \([s_x\ 0\ 0\ s_y\ 0\ 0]\). This scales coordinates so that 1 unit in horizontal and vertical measurements in new coordinate system equals \( s_x \) and \( s_y \) units in old coordinate systems correspondingly.
- Rotations are preformed with matrix \([\cos\theta\ \sin\theta\ \-\sin\theta\ \cos\theta\ \ 0\ 0]\), which matches counter clockwise rotation of all coordinate system by \( \theta \) rad.
- Skew is represented as \([1\ \tan{\alpha}\ \tan{\beta}\ 1\ 0\ 0]\), which matches skew of x axis by \( \alpha \) angle and axis y by \( \beta \).

Image below shows transformation samples. Move direction, rotation and skew angles shown on image correspond to positive matrix values.
Matrix multiplications are not commutative, so it makes difference in which order you multiply matrices.

Table below lists possible transformations and corresponding matrix values.

<table>
<thead>
<tr>
<th>Original picture</th>
<th>Transformed picture</th>
<th>Matrix</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image1" alt="Original" /></td>
<td><img src="image2" alt="Transformed" /></td>
<td>$\begin{bmatrix} 1 &amp; 0 \ 0 &amp; 2 \ 0 &amp; 0 \end{bmatrix}$</td>
<td>Vertical scale. If changed value &gt; 1, object is stretched, otherwise narrowed.</td>
</tr>
<tr>
<td><img src="image3" alt="Original" /></td>
<td><img src="image4" alt="Transformed" /></td>
<td>$\begin{bmatrix} 2 &amp; 0 \ 0 &amp; 1 \ 0 &amp; 0 \end{bmatrix}$</td>
<td>Horizontal scale. If changed value &gt; 1, object is stretched, otherwise shrinks.</td>
</tr>
<tr>
<td><img src="image5" alt="Original" /></td>
<td><img src="image6" alt="Transformed" /></td>
<td>$\begin{bmatrix} -1 &amp; 0 \ 0 &amp; 1 \ 0 &amp; 0 \end{bmatrix}$</td>
<td>Horizontal mirroring.</td>
</tr>
<tr>
<td><img src="image7" alt="Original" /></td>
<td><img src="image8" alt="Transformed" /></td>
<td>$\begin{bmatrix} 1 &amp; 0 \ 0 &amp; -1 \ 0 &amp; 0 \end{bmatrix}$</td>
<td>Vertical mirroring.</td>
</tr>
<tr>
<td><img src="image9" alt="Original" /></td>
<td><img src="image10" alt="Transformed" /></td>
<td>$\begin{bmatrix} 1 &amp; 1 \ 0 &amp; 1 \ 0 &amp; 0 \end{bmatrix}$</td>
<td>Vertical skew up.</td>
</tr>
<tr>
<td><img src="image11" alt="Original" /></td>
<td><img src="image12" alt="Transformed" /></td>
<td>$\begin{bmatrix} 1 &amp; -1 \ 0 &amp; 1 \ 0 &amp; 0 \end{bmatrix}$</td>
<td>Vertical skew down.</td>
</tr>
<tr>
<td><img src="image13" alt="Original" /></td>
<td><img src="image14" alt="Transformed" /></td>
<td>$\begin{bmatrix} 1 &amp; 0 \ 1 &amp; 1 \ 0 &amp; 0 \end{bmatrix}$</td>
<td>Horizontal skew right.</td>
</tr>
</tbody>
</table>
### Clipping Path

Clipping path is vector image containing an object inside. Current version allows only to remove it. To do this, press **Remove** button in **Clipping Path** tab in **Object Inspector**.

Next versions will introduce clipping path editing features.

### Vector Images

Vector images are graphical pictures of geometric shapes like dots, lines, rectangles, circles, ellipses and curves. Vector images need much less space to be stored then raster images.

### Creating Vector Images

Tool for vector images creation are listed below.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Line" /></td>
<td><strong>Line</strong></td>
<td>Draw a straight line of any length.</td>
</tr>
<tr>
<td><img src="image" alt="Rectangle" /></td>
<td><strong>Rectangle</strong></td>
<td>Use to draw rectangles and squares of any size.</td>
</tr>
<tr>
<td><img src="image" alt="Ellipse" /></td>
<td><strong>Ellipse</strong></td>
<td>Draw ellipses and circles of different sizes</td>
</tr>
<tr>
<td><img src="image" alt="Pencil" /></td>
<td><strong>Pencil</strong></td>
<td>Allows to draw custom lines and curves</td>
</tr>
</tbody>
</table>

To draw vector image, choose corresponding tool in the **Insert** menu or press required
button on the toolbar. Left click a spot in the workspace to set coordinates for first object node and drag the cursor in required direction and distance while holding left mouse button.

**Copying and Pasting Vector Images**

Vector images are copied in pasted in Master PDF Editor same way as any other objects in Master PDF Editor.

To copy vector images choose **Edit Document** tool. Select required vector image with left click and choose **Copy (Ctrl+C)** item in the **Edit** menu or right click the image and choose **Copy** command in the context menu. Copied vector image will be stored in the clipboard. It later can be pasted into current or any other Master PDF Editor document.

To paste vector image into Master PDF Editor choose **Paste (Ctrl+V)** item in **Edit** menu or press button on the toolbar. You can also right click the document page choose same command in the context menu. If you paste vector image on current page, it will be located above original image copied to the clipboard. If you paste vector image on another page (or another Master PDF Editor document), it will have same coordinates as original one.

Copied vector image can also be pasted to all document pages or specified pages range. To do it, use **Edit** menu to choose **Paste to Multiple Pages**, p 55.

Vector image can be pasted only into Master PDF Editor. It can’t be pasted into document of any other application.

**Modifying Vector Images**

To align vector images, choose required alignment in **Edit > Align Objects** menu out of provided options: **align by left edge, right edge, top or bottom edge**. Otherwise you can press required button on the **toolbar**: Align Left, Align Right, Align Top, Align Bottom.

**Example:** You need to align several vector images by top edge.

Enter edit mode by clicking **Edit Document** or **Edit Forms** button on the toolbar (or choose one of these items in **Tools** menu). Select required vector images. Alignment works by the top edge of the last selected (active) vector image. **Object Inspector** will display parameters for active vector image. If you
selected a group of vector images at once, there won't be an active vector image, and selected ones will be aligned by the page top edge.

When modifying vector images, 4 tabs are available in **Object Inspector: Geometry, Style, Matrix and Clipping Path**.

![Image of Object Inspector](image)

**Geometry** tab

**Geometry** tab displays settings for active vector image. If a group of vector images was selected with selection box, there won't be an active vector image and **Object Inspector** won't display settings.

- **Width** and **height** — these items of **Geometry** tab allow to specify size of vector image. To do it, select required image and specify the data in corresponding items.
- **Left** — distance from left page border to the left border of the vector image.
- **Top** — distance from top page border to the top border of the vector image.
- **Coordinates** — sets offset when aligning vector images with settings in **left** and **top** items. Coordinates can be **absolute** or **relative**.
• **Relative** — when aligning forms using *top* and/or *left* items distance between vector images remains same.

• **Absolute** — when aligning all vector images will be moved irregularly and will be positioned in coordinate point set in *top* and/or *left* items.

• **Maintain aspect ratio** — if enabled, vector image's aspect ratio isn't changed when its height and width are being modified.

• **Rotate** - allows to rotate vector image.

⚠ Please note, that clipping path (if current vector image has one) won’t be rotated. It should be removed. To do it, go to **Clipping Path** tab of **Object Inspector** and click **Remove** button.

**Style tab**

• **Type** — vector image type. Options: *fill, stroke, fill and stroke.* (It is not always possible to set this item. Some images have only one type – *stroke.*)

Depending on chosen image type, *fill* and *stroke* parameters can be set:

• **Fill** — vector image fill.
  
  ▫ **Color** — color of vector image fill. To choose custom color, press **More…** item in the end of the list.
  
  ▫ **Opacity** — opacity of fill in percents.

• **Stroke** — vector image stroke.
  
  ▫ **Color** — color of vector image stroke line. To choose custom color, press **More…** item in the end of the list.
  
  ▫ **Opacity** — opacity of stroke in percents.
  
  ▫ **Line Thickness** — thickness of stroke line. Can be set with 1 pixel step.

**Matrix** tab.

Transformation matrix serves for vector images transformation. More detailed information can be found in **Transformation Matrix** (p. 57 ).
**Clipping Path** tab.

Information about this tab can be found in **Clipping Path** (стр. 62).

📝 When creating new vector image, options of last changed vector image will be used.

**Text**

Master PDF Editor allows you to search for required information, copy and change text and PDF documents objects in the application directly without converting PDF documents to any other formats.

**Adding Text to Document**

To add text to the document press the button on the toolbar or choose **Insert>Text** menu item. Left click document page. A field with flickering cursor will appear. Here you can type in your text. After typing, click any place of the page.

If text must be moved, left click it, and its box will appear. Press the text with left mouse button and hold it while dragging the text.

**Text Copying and Pasting**

To copy text from PDF document choose **Hand Tool**. Select the text and choose **Copy (Ctrl+C)** item in the **Edit** menu. You can also right click selected text and choose **Copy** item in the context menu. Copied text is stored in the clipboard. You can insert text into a document opened in another application or find another place in Master PDF Editor for it.

To insert text into Master PDF Editor choose **Text** item in **Insert** menu or press the button on the toolbar. Left click document page. A field with flickering cursor will appear. Now you can insert copied text. Right click the field and choose **Paste (Ctrl+V)** in the context menu.

In order to paste text on multiple pages choose **Paste to multiple pages** in **Edit** menu. This will show a dialog window which allows to set pages range for text pasting.
Text Modifying

To edit text choose Edit Text tool in Tools menu or press \textbf{\textbf{T}} button on the toolbar.

Left click text you want to modify. Its box will appear. Text size can be changed by dragging box'es markers. To move text, left click it and drag while holding mouse button.

To align several objects with text choose required option in Edit>Align Objects menu: align by left, right, top and bottom. You can also press according button on the toolbar: \textbf{\textbf{Align Left}}, \textbf{\textbf{Align Right}}, \textbf{\textbf{Align Top}}, \textbf{\textbf{Align Bottom}}

\textbf{Example:} You need to align several boxes with text by left edge. Select them in edit mode. Hold Ctrl key and consequently click required text boxes. Then press \textbf{\textbf{Align Bottom}} button (or choose that item in Edit>Align Objects menu). Text will be aligned by bottom edge of the last selected text box.

If you need to remove part of text text or modify it, right click text in its box and choose Edit text item in the context menu (or double left click text in the box). Instead of the box a text editing field will appear. Move cursor to required location. Now you can modify text in the editing field: remove and add words, copy and replace them etc. You can move cursor in the text with left and right arrows or mouse.

Text attributes can be changed in the edit mode (when text is highlighted with its bounding box) or when text is highlighted with editing field. Master PDF Editor has a special tool called Object Inspector, which provides means to change font settings like family, color, opacity etc. You can open Object Inspector window by clicking its tab in the right part of the application workspace.

When editing text in a window four tabs are available: Geometry, Font, Transformation Matrix and Clipping Path.

\textbf{Font} tab:

\begin{itemize}
  \item \textbf{Font} — specify font family.
  \item \textbf{Size} — specify font size
  \item \textbf{Type} — specify font type. Options: fill text, stroke text, fill and stroke, invisible.
\end{itemize}

Depending on font type, following attributes can be set:

\begin{itemize}
  \item \textbf{Fill Color} — font fill color. For types text "fill" and "fill and stroke".
  \item \textbf{Stroke Color} — font stroke color. For types text "stroke" and "fill and stroke".
\end{itemize}
- **Line Width** — font stroke line width.
- **Opacity** — text opacity for any text type.
- **Character spacing** — space between characters in words.
- **Word spacing** — space between words in the text.
- **Line height** — line height. It is possible to change this setting only for text with multiple lines.

### Geometry Tab

- **Width** and **height** — these two items of the **Geometry** tab allow to specify text object size. To do it, choose text and insert required data in these items.
- **Left** — distance from left page border to the left border of the text object.
- **Top** — distance from top page border to the top border of the text object.
- **Coordinates** — sets offset when aligning text objects with settings in **left** and **top** items.
Coordinates can be absolute or relative.

- **Relative** — when aligning text using top and/or left items distance between text objects remains same.
- **Absolute** — when aligning text all text objects will be moved irregularly and will be positioned in coordinate point set in top and/or left items.

**Maintain aspect ratio** — if enabled, object's aspect ratio isn't changed when its height and width are being modified.

**Example:** You have to move a line of text to the left and set it on defined distance from the page edge.

If the line consists of several text objects, you can choose them by holding Ctrl button and successively clicking them. In coordinates item set relative. Then input required distance in left item. All the text line will be moved to the left, and the distance between text in different boxes will remain same.

**Text Rotation**

To rotate text choose it in editing mode. Open Object Inspector on the Geometry tab. You can rotate text by custom angle by clicking arrow buttons or specifying angle in the corresponding field.

Please note that clipping path won't be rotated if present. It should be removed. To do it, click Remove button in the Clipping Path tab.
Possible Issues with Text

Setting Different Attributes in one Text Object

To change attributes for only one word of text in the edit box, it is not enough to use Object Inspector settings. You have to split single object into several text objects and set font attributes for each one of them.

Impossible to edit text

When trying to edit text an error occurs: «This font doesn't contain these characters. Try choosing another font.»

This happens because of PDF format specialty. When saving PDF file, the application embeds all used characters of the font into that file. However, it doesn’t embed not used character, so if you use font, which was embedded earlier, you can choose characters of a limited set.

For example, if you use Arial font to write a line “12345” and then save PDF file, only these 5 characters of Arial font will be embedded into file. If you open it and try to input another character (like “6”), you’ll see a message about absence of this character in the file.

A simple workaround for this kind of issue is to use Object Inspector to change font family for text object you’d like to edit.

Master PDF Editor has Automatically change font when editing text option in Settings → Editing tab. It works if current font (Arial in the sample above) is installed in the system.
Comments

Comments are used to review text or suggest possible changes in PDF document. They aren't editing tools since their usage doesn't alter source file content. Master PDF Editor allows to move, change and remove comments. If document is password protected, you cannot create and edit comments without entering password.

Adding Comments to Document

Comment tools are available when Hand Tool is active. Master PDF Editor uses following comment tools:

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Add Sticky Note" /></td>
<td>Add Sticky Note</td>
<td>Note can be located in any place of the document, where you want to leave your remarks. Note's title includes PC name. Title can be edited.</td>
</tr>
<tr>
<td><img src="image" alt="Text Highlight" /></td>
<td>Text Highlight</td>
<td>Selected text is displayed on colored background. Allows to mark important places in the text.</td>
</tr>
<tr>
<td><img src="image" alt="Text Strikethrough" /></td>
<td>Text Strikethrough</td>
<td>Selected text is striken through. Usually this type of comments indicates requirement to remove text.</td>
</tr>
<tr>
<td><img src="image" alt="Text Underline" /></td>
<td>Text Underline</td>
<td>Selected text is underlined. Attracts additional attention to the text.</td>
</tr>
</tbody>
</table>

You can add the comment by choosing required tool in the Comments menu or by pressing corresponding buttons on the toolbar.

To add note to the document choose Comments > Add Note in the menu or press ![Add Note](image) on the toolbar. Left click a location in the document where you want to place note. Insert note text in a pop up window. When clicking the cross icon note will be minimized and will remain on the page as icon.
To view and edit note's text, double left click its icon.

To highlight, underline or strikethrough a text, choose required tool in the Comments menu or on the toolbar and select required text wit it. Comment tool will be active until Esc key is pressed or another tool chosen.

Previously selected text may also be highlighted, underlined or striken through. (If you need to select a lot of text, Select Text tool is useful. Right click selected text and choose one of the comment types in the context menu.

If required, a description can be added earlier highlighted, underlined or striken through text. To do it, double click selected text with left mouse button. This will open a commenting window, where you can leave your remarks.

Modifying Comments

To edit comments, select Edit Document or Edit Forms tool. These tools allow to change position of note icon by dragging it with mouse, change its size, set notes icons and parameters.

To change note icon size, select it with Edit Document tool and drag its box edges with mouse.

To align comment notes choose required item in menu Edit > Align Objects: align by left edge, right edge, top and down. You can also use one of the tools on the Toolbar (Align Left, Align Right, Align Top, Align Bottom).

You can change comments settings (type, color, opacity etc.) in Object Inspector. You can open Object Inspector window by clicking its tab in the right part of the application workspace. When editing a comment only two tabs are available in the Object Inspector: Geometry and Options.

If you choose Options item in the opened note, then only Options tab will be available in Object Inspector.

Options in Geometry tab are set likewise for any other objects. See detailed description at p. 53 Geometry tab.
Options tab.

- **Author** — user name, filled automatically. Name can be changed in application's Settings on Comments tab.
- **Subject** — comment name.
- **Text** — comment text.
- **Type** — allows to choose comment's icon appearance. It can be circle, cross, check mark etc. Available only for sticky note.
- **Color** — comment color setting.
- **Opacity** — comment opacity setting.
- **Line width** — line width setting. Available only for underlined and striken through text.

**Export and Import Comments Data**

Export of comments data allows to reduce size of transferred data. This function copies comments and records to separate FDF file.

To export comments, choose **Comments > Export Comments Data...** in menu. This will pop up a **Save As...** window, where you can change comments file name and save it. By default, name of comments data file looks like this: (source document name)_comments.fdf.
Example: My document_comments.fdf

When importing comments data, previously exported and saved to FDF file comments data are added to PDF document.

To import comments to the document choose Comments > Import Comments Data... in menu. Choose comments data file in pop up window and press Open button.

Location and content of the comments will be identical to file they were exported from.

If you email a file with comments as full PDF document, all the comments will be displayed when receiver opens the file. You can also send comments as email attachment.

Comments aren't displayed when printing the document.
**Forms**

PDF files can include two kinds of forms: interactive and non-interactive. Interactive form is a PDF form with fields, which can be filled without any additional functions. Non-interactive form is just a file with text and lines to write your data over them. Master PDF Editor allows to fill non-interactive forms with **Insert Text** tool.

Interactive forms can be filled with **Hand Tool**. You can print filled document and save it.

PDF file may contain following kinds of forms:

<table>
<thead>
<tr>
<th>Button</th>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="link_icon" alt="Link" /></td>
<td>Link</td>
<td>Enables user for a quick move to another place of current, attached or any other document, to other files and web sites. Can also be used to initiate predefined event.</td>
</tr>
<tr>
<td><img src="push_button_icon" alt="Push Button" /></td>
<td>Push Button</td>
<td>Allows to initiate predefined event like opening a files, sending data to web-server, forms reset etc.</td>
</tr>
<tr>
<td><img src="check_box_icon" alt="Check Box" /></td>
<td>Check Box</td>
<td>Allows to set enabled or disabled condition. If a form contains several check boxes, users may choose any number of options.</td>
</tr>
<tr>
<td><img src="radio_button_icon" alt="Radio Button" /></td>
<td>Radio Button</td>
<td>Offers a set of options and allows user to choose only one of them when filling a form.</td>
</tr>
<tr>
<td><img src="combo_box_icon" alt="Combo Box" /></td>
<td>Combo Box</td>
<td>Provides user a possibility to choose an item out of a list or specify custom value.</td>
</tr>
<tr>
<td><img src="list_box_icon" alt="List Box" /></td>
<td>List Box</td>
<td>Allows user to choose one or multiple items out of list.</td>
</tr>
<tr>
<td><img src="text_field_icon" alt="Text Field" /></td>
<td>Text Field</td>
<td>Field to specify custom text like name, address, date, phone number etc.</td>
</tr>
<tr>
<td><img src="signature_icon" alt="Signature" /></td>
<td>Signature</td>
<td>Empty field for digital signature.</td>
</tr>
</tbody>
</table>

**Filling Interactive Forms**

If a document contains interactive PDF forms, then you will see a pop up message «This document contains interactive form fields» when opening it. Message will appear if the application’s setting weren’t changed. To set Pop up message display when opening PDF with forms, open **Tools > Settings > Forms** tab. Enable/disable a checkbox near Always hide document message bar item.

Enable **Hand Tool** to fill interactive PDF forms. You can enable menu item **Forms → Highlight Fields**, this will help you notice forms easier, because they will be displayed on color background set in Master PDF Editor **Settings**.

When positioning mouse cursor over form field, it will be changed to one of the following:

- ![Hand Tool](hand_tool_icon) icon will appear when hovering the cursor over a checkbox, radio button, push button,
list or combo box. Depending on field kind, when filling form you’ll have an option to choose an item or several items of predefined set. Left click the field to fill it.

Icon (cursor) will appear when hovering mouse cursor over Text Field. Position a cursor there by left clicking the field. When you’ve finished typing text, press Tab or Shift+Tab to move to the next or previous field. You can also just mouse click a field you want to fill next.

To remove data from all document forms use Reset Forms command in Forms menu. Please note, that forms data won’t be restored with “Undo” command.

You can edit document with PDF forms just like any other PDF document, if file’s author hasn’t restricted this ability.

PDF Forms Properties. Objects Inspector

You can set parameters and define actions for form fields in Objects Inspector.

Geometry Tab

- Width and height — these items of Geometry tab allow to specify size of single or multiple forms at once. To do it, select required form(s) and specify the data in corresponding items.

Geometry tab displays settings for active form only. If a number of forms were selected simultaneously, no active form will be chosen and settings won’t be displayed in Object Inspector.

- Left — distance from left page border to the left border of the form.
- Top — distance from top page border to the top border of the form.
- Coordinates — sets offset when aligning forms with settings in left and top items. Coordinates can be absolute or relative.
  - Relative — when aligning forms using top and/or left items distance between forms remains same.
  - Absolute — when aligning all forms will be moved irregularly and will be positioned in coordinate point set in top and/or left items.
- Maintain aspect ratio — if enabled, form’s aspect ratio isn’t changed when its height and width are being modified.
General Tab

- **Name** — unique form name. Required for correct form fields data import and export.
- **ToolTip** — text which will appear in pop up menu when hovering mouse cursor over the form.
- **Orientation** — data orientation in the form (for all form fields except for links).
- **Form Field** — option of form field display on screen and when printing. Has 4 options: visible; hidden; visible, but not printable; printable, but not visible.
- **Read Only** — if enabled, form won’t be used for filling and users will only be able to view data displayed in this field.
- **Required** — if enabled, form will be required for filling. This item can be enabled for all kinds of form fields except for **List** and **Push Button**.

For your comfort, Master PDF Editor allows to highlight all forms required for filling. Use main menu to choose **Tools > Settings > Forms** (see **Forms Tab**, p. 24).

- **Locked** — if enabled, the application won’t allow fill this PDF form.

Appearance Tab

- **Line Style** — style of lines framing the form. Options: solid, dashed, beveled, inset, underline.
- **Line Thickness** — thickness of lines framing the form. Options: thin, medium, thick.
- **Fill Color** — color of form fill.
- **Border Color** — color of lines bordering the form.

**Object Inspector** allows to specify size, color and font family for records in all form fields except for check boxes and radio buttons. Records themselves are specified in **Options** tab.

- **Size** — records font size. If set to Auto, font size will be changed accordingly to the form’s size.
- **Color** — records font color.
- **Font** — records font family.
Options Tab

Options tab contains individual settings for different form fields.

Actions tab

Master PDF Editor allows to choose predefined actions out of a set of options. Item Trigger allows to specify kind of action, which must be conducted in order for current action to be performed. Following user actions can be set as events: Mouse Up, Mouse Down, Mouse Enter, Mouse Exit, On Receive Focus, On Lose Focus.

Actions item allows to specify kind of action to be performed after trigger fired: Goto a Page View, Open/execute a file, Open a web link, Reset form, Show/hide fields, Submit a form, Run a JavaScript.

Choose required trigger and specify action to be performed. Press Add button. This will pop up a dialog window, which allows to specify data depending on Action option.

- Goto a Page View — set page number and scale.
- Open/execute a file — opens or launches local file from the drive. Input file name or press Browse button to choose a file in dialog window.
- Open a web link — opens link in default web browser. Specify a link in dialog window.
- Reset form — resets form values in the document. Default values will be set or form fields will be emptied.
- Show/hide fields — hides or shows a form, specified in dialog window.
- Submit a form — sends data of chosen forms in specified formats. Currently Master PDF Editor allows to send data only in FDF formats. Data can be saved to local file or sent with FTP or HTTP. (File delivery via email is currently not supported in Master PDF Editor)
  ▪ When saving data to local file specify file name or choose it in dialog window with Browse button.
  ▪ When sending to FTP server specify server address, user name and password if required. Otherwise enable Anonymous checkbox.
  ▪ When sending to HTTP or HTTPS server, specify server address.
- Run a JavaScript — execution of your JavaScript code.
Aligning Interactive PDF forms

To align interactive PDF forms, use following toolset on the toolbar: Align Left, Align Right, Align Top, Align Bottom, or choose required option in menu Edit>Align Objects: align by left edge, right edge, top or bottom edge.

For example, you need to align several buttons by the left edge. Select these buttons in editing mode. To enable it, press Edit Document or Edit Forms button on toolbar or choose either of these tools in Tools menu. You can select multiple buttons by holding Ctrl key and successively clicking required buttons. Last selected button will be considered active, and all selected buttons will be aligned by its left edge. Its settings will be displayed on Object Inspector window. However, if you have selected all these buttons at once, none will be active and buttons will be aligned by page edge. Also see Aligning Objects p.53.

Creating and Modifying Interactive PDF Forms

One of the most demanded functions of PDF editors is a possibility to create PDF forms. Master PDF Editor allows to place in documents any interactive forms, which later can be filled, signed with digital signature, printed, saved or sent via email.

In Forms menu you can choose an option for new form fields creation. Forms settings are displayed in Object Inspector window. It allows to specify settings for one or multiple forms at once.

To edit form fields, enable editing mode by pressing Edit Document or Edit Forms button on toolbar or choosing either of these tools in Tools menu.

Link

Link enables user for a quick move to another place of current, attached or any other document, to other files and web sites. Can also be used to initiate predefined event.

To add link to the document choose Forms > Link (Ctrl+L) in menu or press Insert Link button on the toolbar. This will show a marker, allowing you to choose field for link (Tool can be deactivated with Esc or right mouse button). You can set options and define actions for link in Object Inspector.

Geometry tab allows enables user for more precise positioning of the link field on the document page. For more details see Geometry, p. 53 and p. 76.

Following settings can be set for link in Options tab:
- **Line Thickness** — thickness of lines framing the link (in pixels).
- **Line Color** — color of lines framing the link.
- **Line Style** — style of lines framing the form. Options: *solid, dashed, underline*.
- **Highlight** — setting is currently not supported. Feature added only for compatibility with other editors.

**Actions** tab allows to set kind of action and a trigger, which has to be fired in order for the action to be performed.

**Trigger** item is used to specify kind of event, which must be initiated by user for defined action to be performed. Following actions (events) can be set as trigger: *Mouse Up, Mouse Down, Mouse Enter, Mouse Exit, On Receive Focus, On Lose Focus*.

**Action** item allows user to specify kind of action, which will be preformed after trigger is fired: *Goto a Page View, Open/execute a file, Open a web link, Reset form, Show/hide fields, Submit a form, Run a JavaScript*.

Link attributes can be changed any moment according to your requirements.

**Push Button**

To create a push button, choose corresponding item in **Forms** menu. Click a spot of the document page, where you want to locate the button. Application will create a button of default size. Instead, you can hold left mouse button and draw a rectangle box of required size. You can create multiple instances of push button. Names of newly created button are same as first button’s name, but with index number. If you create new buttons by copying the first one, they will have completely identical name. Button copies work independently of each other.

If required, copied button can be pasted to all pages of the document or specific range of pages. To do it, choose **Paste to multiple pages** item in **Edit** menu.

Settings for buttons in **Object Inspector Geometry, General, Appearance** and **Actions** tabs are similar to these settings for other form fields. See PDF Forms Properties p. 76, and Geometry p. 53.

**Options** tab

- **Behavior** — sets option of button behavior on mouse click: *invert, push, outline, none*.
- **Up Label** — text label to be displayed on button in inactive state.
- **Down Label** — text label to be displayed on button in pressed state.
- **RollOver Label** — text label to be displayed on button when received focus.
Check Box

Check box is used to provide a user Yes/No kind of input to express agreement with document items. Usually this kind of form is used when required to choose several options out of a list. If only one option has to be chosen, then radio buttons are usually used. To create a check box on the document, choose Forms > Check Box in menu.

Settings for check boxes in Object Inspector window are identical to other form fields settings in Geometry, General, Appearance, Actions tabs. See PDF Forms Properties p. 76 and Geometry p.53.

When creating a check box, it is possible to make it required to be filled by user. To do it, check Required item in General tab of Object Inspector window. When user fills forms, required fields are highlighted.

Options tab. Style item allows to choose check box kind: check, circle, cross, diamond, square, or star. Export Value item is used to specify a value for export, if the field is enabled by user when filling forms. If Checked by Default is enabled, check box will be checked when resetting forms (menu item Forms > Reset Forms resets data in all document forms. Fields are set to default values or cleared, if there’s no default value.)

Please note, that right after this option is enabled, check box won’t be checked by default. You have to Reset Forms first.

Master PDF Editor allows to set several behavior patterns for check boxes:

- To make other check boxes enable themselves when one of them is enabled by user, all of these check boxes are to have identical Names (General tab) and same Export Values (Options tab). Such fields can be located at different pages.
- For a possibility to choose only one check box out of a group, all the group has to have same Names and different Export Values.
- For check boxes to be filled independently from each other, their Names and Export Values have to be different.

All the actions with check boxes (creation, movement, resizing, creating copies, duplicating and removing) are conducted same way as for all other kinds of form fields.

Radio Button

To create radio button form field, choose Forms > Radio Button menu item. Radio button is most common way to give user possibility to choose one option out of a set. Radio buttons
always work in groups unlike check boxes. Accordingly, all the form fields of a radio button group have to own identical Names (General tab) and different Export values (Options tab). All radio button settings are identical to those of check boxes.

All the actions with radio buttons (creation, movement, resizing, creating copies, duplicating and removing) are conducted same way as for all other kinds of form fields.

All the radio button settings in Object Inspector window are identical to other form fields settings in Geometry, General, Appearance, Actions tabs. See PDF Forms Properties p. 76 and Geometry p.53.

List Box

Choose Forms > List Box menu item to create a list.

When filling, user may choose one or multiple list box items. Possibility of such choice depends on settings, applied by the document’s author. When creating several list box fields in PDF document, all of them have to own unique names (General tab).

Options tab.

Item — to add an item to the list, specify its text in item field and click Add button. To remove it from the list, choose the item in the list and click Delete button.

Export value — if required for export value to be different from selected list item when exporting data, specify custom export value at this item. (If Export value isn’t set, it will be automatically set to the text of the chosen item.)

Up and Down — these buttons allow to move selected item up and down the list.

Sort Items — if enabled, buttons Up and Down are locked, and list items are automatically sorted in alphabet order.

Multiple selection — if enabled, users will be able to select multiple items of the list.

Commit selected value immediately — if enabled, value as saved right after user selects it. If disabled, value is saved only when user switches focus from current field to another form.

All the actions with lists (creation, movement, resizing, creating copies, duplicating and removing) and settings in Geometry, General, Appearance, Actions tabs are same as for all other kinds of form fields. See PDF Forms Properties p. 76 and Geometry p. 53.
**Combo Box**

With combo box user can choose an item out of a predefined set or specify custom value.

Settings of combo box in **Options** tab are same to those of a list box, except for the only item *Allow user to enter custom text*. If this item is enabled, user may enter custom value when filling the form.

**Edit Box**

Edit box allows user to enter custom text when filling PDF form.

To create edit box choose **Forms>Edit Box** menu item and click a spot of the document page, where you want to locate edit box. Application will create an edit box of default size. Instead, you can hold left mouse button and draw a rectangle box of required size.

When creating multiple edit boxes in PDF document, they all have to own unique **names** (**General** tab). In case it’s not done, data will be duplicated in all edit boxes with same name when one of them is filled by user.

**Options** tab.

*Formatted text* — if enabled, possible to enter formatted text (bold, italic, underline etc.) (Current version doesn’t support formatted text.)

*Alignment* — this item allows to specify text position in form field (left, center, right).

*Default value* — allows to specify default text.

*Multi-line* — if enabled, entered text will be written to separate lines. Otherwise all text is written into single line.

*Password* — if enabled, text will be displayed as start when entered by user. (Available only if *Check spelling* is disabled)

*Scrollable* — if enabled, user may input text, which exceeds the borders of the edit box.

*Check spelling* — if enabled, spell-check is preformed on the text in the edit box.

*Limit to* — allows to specify maximal amount of characters to be entered by user.

*Split into* — allows to split edit box into specified number of cells for characters input.
Import and Export Forms Data

This function is available only for interactive PDF forms. When using export, forms data are copied into specified fbf format file.

When importing data to the document, previously exported and saved in fdf file data containing results of PDF forms filling are added.

Unlike comments, only forms data can be imported and exported.

But like comments, forms data export help decrease size of transferred data. To export forms data, choose **Forms > Export Form Data…** item in Main menu. A **Save As…** window will appear, which allows you to set name and path for data file and save it with **Save** button. By default data file is named like: (source document name)_form.fdf.

**Example**: *My document_form.fdf*

To import forms data into the document, choose **Forms > Import Form Data…** item in Main menu. Use following pop up window to choose file with data and press **Open** button.

Forms content will be identical to file they were exported from.
Digital Signature

In recent years most companies switched to different methods of electronic document management. This allows to drastically shorten time for business clearance, simplifies document accounting and archiving. But electronic document management also rises the issue of documents authenticity and validation,

Digital signature is an effective way to protect document from changes and identify true sender.

Digital signature ensures that signed document wasn't changed by anyone other than its author. It is most common way to authenticate document content. PDF signature has numeric ID, provided by trusted certificate center.

Master PDF Editor allows to validate digital signatures, create them and sign documents.

Creating Signature and Signing

Document must be signed after its editing is over. If the document was changed after signing, these changes might corrupt the signature.

To create a signature you have to receive its numeric ID and preform following actions:

- Choose **Forms > Signature** in Main menu or click **Signature** button on the toolbar. In a document, choose a rectangle where digital signature must be located.

- Choose **Tools > Hand Tool** in Main menu or press **Hand Tool** (Alt+4) button on the toolbar. To create a signature left click a signature form. (If Edit Document or Edit Forms is selected, left click twice) When **Signature Properties** window has popped up, choose required certificate in **Sign As** field.

In Mac and Windows certificate must be previously copied to system certificate storage. In Linux you have to open certificate file (as a rule, it has .p12 extension) and enter closed key passowrd.
▪ Press **Sign** button.

In Mac OS you'll have to allow application's acces to certificate storage. When signing, you'll be prompter for file name and location. Choose file name to sign and save PDF document.

**Digital Signature Validation**

Master PDF Editor can be used to validate signatures in PDF files. If Edit Document or Edit Forms tool is on, double click certificate or click it once if **Hand Tool** is on. You'll see a window with certificate validation result.
Signature is VALID

Signature is valid, document wasn't changed after signing and certificate was provided by trusted certification center.

Signature is INVALID

Issues occurred when validating the signature. Document was changed or damaged after signing.

Signature validity is UNKNOWN

Signature is valid, document wasn't changed after signing, but certificate isn't trusted.

To make certificate trusted:

For Windows и Mac OS X: You must add certificate's open key to system certificate storage.

For Linux: Press Information button, view certificate properties and then press Add to Trusted Identities button.
Print

PDF Document Printing

You can print the document only if your computer is connected to local or network printer and it has required drivers installed.

- Choose **File > Print** item in Main menu or press **Print** (Ctrl+P) button on the toolbar.
- Choose one of the available devices for printing in following pop up window.
- Specify pages to print: all, current page, selected pages or pages range.
- Specify number of document copies.
- Press **Print**.

Print Preview

Print preview allows to set printing with additional settings.

To do it, choose **File > Print Preview** item in Main menu.
**Printer.** Name of the printer to be used for printing. Use its properties to set paper size and orientation (portrait, landscape) and margins.

**Pages range** All pages, current page or specific pages range.

**Aspect ratio** Applied when actual PDF page size and printer paper size or different, i.e. page can take only a little of printed sheet’s area or exceed its borders. This option is disabled and ignored if **Actual size** is enabled.

- **Ignore aspect ratio.** Stretches page to printer sheet size.
- **Keep aspect ratio.** Stretches page to shortest sheet side saving aspect ratio.
- **Keep aspect ratio by expanding.** Stretches page to longest sheet side saving aspect ratio.

If document has different color spectrum, and you want to print it with black-and-white printer, enable **Print as Grayscale** option.

To print page in actual size, enable **Actual Size** option.

**Center** item allows to locate printed page in the center of the sheet.

**Orientaion** (landscape, portrait).

**Page.** Choose page for preview before print.
Hotkeys

Every user has his own habits of work on his keyboard. Master PDF Editor provided possibility to set keyboard shortcuts according to individual preferences, which can drastically increase speed of your work with Master PDF Editor.

Following hotkeys can help you navigate document in Master PDF Editor faster:

<table>
<thead>
<tr>
<th>File menu</th>
<th>Window and Linux</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>New</td>
<td>Ctrl + N</td>
<td>Cmd + N</td>
</tr>
<tr>
<td>Open</td>
<td>Ctrl + O</td>
<td>Cmd + O</td>
</tr>
<tr>
<td>Save</td>
<td>Ctrl + S</td>
<td>Cmd + S</td>
</tr>
<tr>
<td>Save As..</td>
<td>Ctrl + Shift + S</td>
<td>Cmd + Shift + S</td>
</tr>
<tr>
<td>Paste to Multiple Pages</td>
<td>Ctrl + Alt + S</td>
<td>Cmd + Alt + S</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl + P</td>
<td>Cmd + P</td>
</tr>
<tr>
<td>Print Preview</td>
<td>Ctrl + Shift + P</td>
<td>Cmd + Shift + P</td>
</tr>
<tr>
<td>Properties</td>
<td>Ctrl + D</td>
<td>Cmd + D</td>
</tr>
<tr>
<td>Close</td>
<td>Ctrl + W</td>
<td>Cmd + W</td>
</tr>
<tr>
<td>Exit</td>
<td>Alt+F4 или Ctrl+Q</td>
<td>Cmd+Q</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Edit menu</th>
<th>Window and Linux</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cut</td>
<td>Ctrl + X</td>
<td>Cmd + X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl + C</td>
<td>Cmd + C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl + V</td>
<td>Cmd + V</td>
</tr>
<tr>
<td>Delete</td>
<td>Del</td>
<td>Delete</td>
</tr>
<tr>
<td>Select All</td>
<td>Ctrl + A</td>
<td>Cmd + A</td>
</tr>
<tr>
<td>Undo</td>
<td>Ctrl + Z</td>
<td>Cmd + Z</td>
</tr>
<tr>
<td>Redo</td>
<td>Ctrl + Y</td>
<td>Cmd + Y</td>
</tr>
<tr>
<td>Send to Back</td>
<td>Ctrl + Shift + -</td>
<td>Cmd + Shift + -</td>
</tr>
<tr>
<td>Bring to Front</td>
<td>Ctrl + Shift ++</td>
<td>Cmd + Shift ++</td>
</tr>
<tr>
<td><strong>View menu</strong></td>
<td><strong>Window and Linux</strong></td>
<td><strong>Mac OS X</strong></td>
</tr>
<tr>
<td>--------------------</td>
<td>----------------------</td>
<td>-----------------------</td>
</tr>
<tr>
<td>First Page</td>
<td>Home</td>
<td>Fn + Left Arrow</td>
</tr>
<tr>
<td>Previous Page</td>
<td>Page Up</td>
<td>Fn + Up Arrow</td>
</tr>
<tr>
<td>Next Page</td>
<td>Page Down</td>
<td>Fn + Down Arrow</td>
</tr>
<tr>
<td>Last Page</td>
<td>End</td>
<td>Fn + Right Arrow</td>
</tr>
<tr>
<td>Zoom In</td>
<td>Ctrl + +</td>
<td>Cmd + +</td>
</tr>
<tr>
<td>Actual Size</td>
<td>Ctrl + 0</td>
<td>Cmd + 0</td>
</tr>
<tr>
<td>Zoom Out</td>
<td>Ctrl + -</td>
<td>Cmd + -</td>
</tr>
<tr>
<td>Fit Page</td>
<td>Ctrl + 1</td>
<td>Cmd + 1</td>
</tr>
<tr>
<td>Fit Width</td>
<td>Ctrl + 2</td>
<td>Cmd + 2</td>
</tr>
<tr>
<td>Facing Pages</td>
<td>Ctrl + 3</td>
<td>Cmd + 3</td>
</tr>
<tr>
<td>Find</td>
<td>Ctrl + F</td>
<td>Cmd + F</td>
</tr>
<tr>
<td>Find Next</td>
<td>F3</td>
<td></td>
</tr>
<tr>
<td>Object Inspector</td>
<td>Ctrl + F11</td>
<td>Cmd + F11</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Insert menu</strong></th>
<th><strong>Window and Linux</strong></th>
<th><strong>Mac OS X</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Text</td>
<td>Ctrl + T</td>
<td>Cmd + T</td>
</tr>
<tr>
<td>Image</td>
<td>Ctrl + I</td>
<td>Cmd + I</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Comments menu</strong></th>
<th><strong>Window and Linux</strong></th>
<th><strong>Mac OS X</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Add Sticky Note</td>
<td>Ctrl + 6</td>
<td>Cmd + 6</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Forms menu</strong></th>
<th><strong>Window and Linux</strong></th>
<th><strong>Mac OS X</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>Highlight Fields</td>
<td>Ctrl + H</td>
<td>Cmd + H</td>
</tr>
<tr>
<td>Edit Forms</td>
<td>Alt + 3</td>
<td>Control + 3</td>
</tr>
<tr>
<td>Link</td>
<td>Ctrl + L</td>
<td>Cmd + L</td>
</tr>
<tr>
<td>Edit Box</td>
<td>Ctrl + E</td>
<td>Cmd + E</td>
</tr>
</tbody>
</table>
## Master PDF Editor®

### Hotkeys

<table>
<thead>
<tr>
<th>Document menu</th>
<th>Window and Linux</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Blank Pages</td>
<td>Ctrl + Shift + N</td>
<td>Cmd + Shift + N</td>
</tr>
<tr>
<td>Delete Pages</td>
<td>Alt + Del</td>
<td>Fn + Option + Delete</td>
</tr>
<tr>
<td>Crop Pages</td>
<td>Ctrl + K</td>
<td>Cmd + K</td>
</tr>
<tr>
<td>Page layout</td>
<td>Ctrl + Shift + L</td>
<td>Cmd + Shift + L</td>
</tr>
<tr>
<td>Rotate Pages</td>
<td>Ctrl + R</td>
<td>Cmd + R</td>
</tr>
<tr>
<td>Extract Pages...</td>
<td>Ctrl + Shift + E</td>
<td>Cmd + Shift + E</td>
</tr>
<tr>
<td>Insert Pages...</td>
<td>Ctrl + Shift + I</td>
<td>Cmd + Shift + I</td>
</tr>
<tr>
<td>JavaScript Console</td>
<td>Ctrl + J</td>
<td>Cmd + J</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Tools menu</th>
<th>Window and Linux</th>
<th>Mac OS X</th>
</tr>
</thead>
<tbody>
<tr>
<td>Edit Document</td>
<td>Alt + 1</td>
<td>Control + 1</td>
</tr>
<tr>
<td>Edit Text</td>
<td>Alt + 2</td>
<td>Control + 2</td>
</tr>
<tr>
<td>Edit Forms</td>
<td>Alt + 3</td>
<td>Control + 3</td>
</tr>
<tr>
<td>Hand Tool</td>
<td>Alt + 4</td>
<td>Control + 4</td>
</tr>
<tr>
<td>Select Text</td>
<td>Alt + 5</td>
<td>Control + 5</td>
</tr>
</tbody>
</table>

If you hold Ctrl(Cmd) key when scrolling mouse wheel, this will increase/decrease current zoom.

Hold Ctrl(Cmd) and left mouse button to choose several objects at once. To cancel selection of one of the selected objects, left click it again while holding Ctrl(Cmd) key.

Information about default system keyboard shortcuts can be found on following pages:


Virtual PDF Printer

With Master PDF Editor you can easily print any documents from any applications, which support printing (for example, Microsoft Word and Excel or OpenOffice).

Master PDF Editor is installed as virtual PDF printer. After successful installation it appears in your list of Printers and Faxes. In order to create PDF file, you have just to print the document with Master PDF Editor. Open document (with Microsoft Word, WordPad, NotePad or any other application), press Print and choose Master PDF Editor printer (see screenshot).

This will open Master PDF Editor with your “printed” document. To save it as PDF file, choose File > Save As… item in Main menu.
Available paper sizes:


Available resolution (DPI):

100×100, 200×200, 300×300, 600×600, 1200×1200.

Virtual PDF printer is included only with Master PDF Editor version for Windows Vista, 7, 8 and Windows 10.
License Agreement

Code Industry Ltd (hereinafter referred to as the “Author”) hereby grants you a non-exclusive license (hereinafter referred to as the “License”) to use the software Master PDF Editor (hereinafter referred to as the “Software”) on the terms set forth hereunder.

1. GRANT OF LICENSE.

This License grants you the following rights. By installing the Software you accept the License and agree to comply with it.

2. SOFTWARE.

Install and use one copy of the Software for a single user. You may also install a copy for that user’s exclusive use on either a home or portable computer. If you want to install and use the copy in the network (on a computer file server) you need to purchase an additional license for all users with access to this Software. Software for Desktop Linux is provided by Author free for non-commercial use.

3. NON-COMMERCIAL USE.

You are hereby granted to use this Software for non-commercial purposes without charge for unlimited time on Desktop Linux. Software can also be used for viewing and printing documents on Windows and Mac OS X for unlimited time without any charge.

4. REVERSE ENGINEERING.

You may not modify, reverse engineer, decompile, disassemble, or create derivative works based on the Software, or any portion hereof.

5. RENTAL.

You may not rent or lease the Software.

6. TRANSFER.

You may transfer the Software to a single recipient on a permanent basis provided that you retain no copies of the Software (including backup or archival copies) and the recipient agrees to the terms and conditions of this License.

7. TERMINATION.

The License is in effect until terminated. The License will terminate automatically if you fail to comply with the limitations described herein. On termination, you must destroy all copies of the Software and Documentation.

8. USE OF LOGOS AND TRADEMARKS.
You may not use the Author’s name, logos, or trademarks in any manner including, without limitation, in your advertising or marketing materials, except as is necessary to affix the appropriate copyright notices as required herein.

9. MISCELLANEOUS.

This Agreement represents the complete agreement concerning this License between the parties and supersedes all prior agreements and representations between them. This Agreement may be amended only in writing and when executed by both parties. THE ACCEPTANCE OF ANY PURCHASE ORDER PLACED BY YOU IS EXPRESSLY MADE CONDITIONAL ON YOUR ASSENT TO THE TERMS SET FORTH HEREIN, AND NOT THOSE CONTAINED IN YOUR PURCHASE ORDER. If any provision of this Agreement is held to be unenforceable for any reason, such a provision shall be reformed only to the extent necessary to make it enforceable and the remainder of this Agreement shall nonetheless remain in full force and effect.

10. LIMITED WARRANTY:
THE SOFTWARE IS PROVIDED “AS IS” WITHOUT A WARRANTY OF ANY KIND. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, THE AUTHOR FURTHER DISCLAIMS ALL WARRANTIES, INCLUDING WITHOUT LIMITATION ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FITNESS FOR A PARTICULAR PURPOSE AND NON INFRINGEMENT. THE ENTIRE RISK ARISING OUT OF THE USE OR PERFORMANCE OF THE SOFTWARE AND DOCUMENTATION REMAINS WITH THE RECIPIENT.

11. LIMITATION OF LIABILITY:
UNDER NO CIRCUMSTANCES AND UNDER NO LEGAL THEORY, TORT, CONTRACT, OR OTHERWISE, SHALL THE AUTHOR OR HIS SUPPLIERS OR RESELLERS BE LIABLE TO YOU OR ANY OTHER PERSON FOR ANY INDIRECT, SPECIAL, INCIDENTAL, OR CONSEQUENTIAL DAMAGES OF ANY CHARACTER INCLUDING, WITHOUT LIMITATION, DAMAGES FOR LOSS OF GOODWILL, WORK STOPPAGE, COMPUTER FAILURE OR MALFUNCTION, DATA LOSS, OR ANY AND ALL OTHER COMMERCIAL DAMAGES OR LOSSES, OR FOR ANY DAMAGES IN EXCESS OF THE AUTHOR’S LIST PRICE FOR A LICENSE TO THE SOFTWARE AND DOCUMENTATION, EVEN IF THE AUTHOR SHALL HAVE BEEN INFORMED OF THE POSSIBILITY OF SUCH DAMAGES, OR FOR ANY CLAIM BY ANY OTHER PARTY. THIS LIMITATION OF LIABILITY SHALL NOT APPLY TO LIABILITY FOR DEATH OR PERSONAL INJURY TO THE EXTENT THAT THE APPLICABLE LAW PROHIBITS SUCH LIMITATION. FURTHERMORE, SOME STATES DO NOT ALLOW THE EXCLUSION OR LIMITATION OF INCIDENTAL OR CONSEQUENTIAL DAMAGES AND, THEREFORE, THIS LIMITATION AND EXCLUSION MAY NOT APPLY TO YOU.

Copyright © Code Industry Ltd All rights reserved.